Closed Bug 1415492 Opened 2 years ago Closed 2 years ago

Activity Stream is only disabled/enabled after the second new tab is opened

Categories

(Firefox :: New Tab Page, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox56 --- affected
firefox57 --- wontfix
firefox58 --- fix-optional

People

(Reporter: cmuresan, Unassigned)

References

Details

Attachments

(1 file)

[Affected versions]:
- Firefox 58.0a1 Build ID 20171106100122

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Steps to reproduce]:
1. Open the browser and navigate to about:config.
2. Click "I accept the risk!" and search for browser.newtabpage.activity-stream.enabled.
3. Set the pref to "false".
4. Open a new window and observe the behavior.
5. Open another new window and observe the behavior.

[Expected results]:
- Step 4 & 5: The old about:newtab is displayed.

[Actual results]:
- Step 4: Activity Stream is displayed.
- Step 5: The old about:newtab is displayed.

[Notes]:
- The issue is also reproducible when you enable Activity Stream.
- Attached a screen recording of the issue.
Steps are different but this is revealing the same behavior as bug 1415491.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
We've been doing this ever since Activity Stream entered Nightly, when we didn't cache anything.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
wontfix this, as Tiles is going away
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → WONTFIX
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.