Creating new folder with a period in the name under IMAP account does nothing

RESOLVED DUPLICATE of bug 1247379

Status

Thunderbird
Folder and Message Lists
RESOLVED DUPLICATE of bug 1247379
12 days ago
8 days ago

People

(Reporter: stig, Unassigned)

Tracking

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 days ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.75 Safari/537.36

Steps to reproduce:

1. Right-click mail account
2. Create new folder
3. Put a . (period) in the name, e.g. "example.com Project"
4. Click 'Create folder'


Actual results:

Folder creation prompt closes, but the folder is nowhere to be seen. Nor does an error message appear.


Expected results:

A folder with the name "example.com Project: should have been created under the root node of the IMAP account.

Comment 1

12 days ago
Lots of old bugs about periods https://mzl.la/2hf5Wo0
But nothing current like this report
That creates a folder "example" with a folder "com" inside.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1247379

Comment 3

8 days ago
This works for me on all of my many test account, even with the reporter's same folder name.
I'm curious as to what imap server the reporter is using? Maybe it uses . as the hierarchy delimiter?

Most servers, it seems, report a "hierarchy delimiter" of / so that if you create a folder gene/smith you get a top level folder gene with folder smith below it (but folder gene is not selectable and appears gray in tb). To make them both selectable you can create gene first followed by gene/smith, doing this from the top level.

I've seen some discussion that you might be able to encode the delimiter in the folder name by escaping without creating a new level, but the example I tried didnt' work in tb on servers I tried (the escape stuff just became part of the new folder name).

Comment 4

8 days ago
I do see one possible bug here. The reporter says the folder was not created and tb did not report this. When I create a folder with a very long name, the server reports back via imap "NO Mailbox name too long". There is no immediately visible indication of this error in tb (other than the fact that the folder was not created). However, when I look in "activity manager" I do see the failed attempt listed for the server.

Also, bug 1247379, that this is marked as a duplicate of, is actually expected behavior when the imap server's delimiter is a dot.
(Reporter)

Comment 5

8 days ago
I got some IMAP server logs now. Attempting to create a folder called "foo.bar":

-1607469312[7f12a1141220]: a0c6c000:.example.com:A:ProcessCurrentURL: entering
-1607469312[7f12a1141220]: a0c6c000:.example.com:A:ProcessCurrentURL:imap://username@.example.com:993/create%3E/foo.bar:  = currentUrl
-1607469312[7f12a1141220]: a0c6c000:.example.com:A:SendData: 18 create "foo.bar"
-1607469312[7f12a1141220]: ReadNextLine [stream=a0331c80 nb=59 needmore=0]
-1607469312[7f12a1141220]: a0c6c000:.example.com:A:CreateNewLineFromSocket: 18 NO [CANNOT] Character not allowed in mailbox name: '.'

I agree. It would be nice if these server errors bubbled up to the user interface.
You need to log in before you can comment on or make changes to this bug.