Closed Bug 141619 Opened 18 years ago Closed 9 years ago

Treat bookmark folders as bookmark groups

Categories

(SeaMonkey :: Bookmarks & History, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bamm, Unassigned)

References

Details

It would be more intuitive if there were no distinction between bookmark
folders and bookmark groups. Instead, we should be able to right-click on
any folder and choose "Open all in new tabs" and it will open all its
contents in new tabs, in addition to the tabs already present in the
current window.
Severity: normal → enhancement
I like this idea.
I followed the open groups in tabs enhancement concept for a while. Now that
it's published I find that it doesn't work like I envisioed it would. This is
what I envisioned. It would seem so much simpler from a programing and user
standpoint.
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
If there were no distinction between folders and multitab bookmarks, the feature
'open all the content of a folder in new tabs' would be unnoticable from end-user.
I think the multitab icon is needed to draw the attention on this new feature.

I prefer the solution given in bug 134799: Make any bookmark folder into a
bookmark group from folder properties window.
I second the idea that not all the folders need to be open in tabs, but that the
choice should be reversible.

cc'ing mpt for further discussion.
I guess I view opening bookmarks as groups as a user process, rather than a
feature of the software. It's just another way to use bookmarks, combined with tabs.

OTOH, the bug you cite to make it possible to change folders into groups and
vice versa sounds acceptable. It would just be even better if users didn't have
to create something new to learn about/use the "groups in tabs" feature.

If you play with groups in the bookmark manager it kinds of works like this now
... but not by design. Create a group ... drag it into a folder. Now what's in
the folder? On my build it's a now a folder, not a group. I cannot imagine that
this is WAD.
There is a bug somewhere about bookmarks having a context menu like in IE.

People like to try right-clicking on anything to see what it offers, and
having "Open all in new tabs" is a gee-whiz feature they would surely discover.

Surely much more noticeable than an option to "Convert to Bookmark Group",
which, after they convert, all they will notice is the change in icon.

Since /some/ folders can be opened as tabs, why not all? I believe this
solution is much more in tune with the way the common user thinks than
any other solution thus proposed.
If a user tries to open a folder with many entries, there should be a warning
that he is about to open a large number of tabs which may slow down his
connection, and ask him if he wants to continue.
I believe the number of tabs that can be opened at once should be part of the
user settings in "preferences, navigator, tabbed browsing". A user would be able
to enter a number for the maximum tabs that would be opened during "open folder
contents in tabs".

A default number might be something like "6", meaning that only the first 6
links in the folder would open. A user could make this setting any number they
want, perhaps up to 99, as a max two digit number.
Personally, I think it would most useful if we still have bookmark groups but
also have an 'Open All In New Tabs' option on the context menu of bookmark
folders. I'm concerned that the average user would find that too complicated though.

A 'Convert to Bookmark Group' option would be useful, but should really be spun
off into its own RFE.
Alex: Great suggestion. Question: if folders can be opened as tabs, what would
bookmark groups be for? Easy single-click access?
> Question: if folders can be opened as tabs, what would bookmark groups be for?
> Easy single-click access?

Yes. The problem is taht right now you can only get context menus for bookmarks
in the Sidebar and Manage Bookmarks window. It would be way to difficult to open
groups of tabs if you had to go there each time.
You are right. Bookmark menus should have context menus too, because they
are also links from a users viewpoint, and deserve the same set of choices,
but that is another bug.

Given this situation your suggestion seems best.

How about Ctrl+Click on a bookmark folder to open them in new tabs?
Bug 50504 - Context menu for bookmarks menus
Blocks: 142683
> A 'Convert to Bookmark Group' option would be useful, but should really be spun
> off into its own RFE.

Covered by bug 134799.
No longer blocks: bm-group-tracker
*** Bug 151152 has been marked as a duplicate of this bug. ***
> How about Ctrl+Click on a bookmark folder to open them in new tabs?

I don't like that any more than I like the context menu idea - both because of a
lack of discoverablity.  Although context menus have a bit of an advantage over
a key binding.

Rather than have "Open all in new tabs" as part of a context menu - where the
feature remains undiscovered by those new to it until the chance upon it by
right-clicking - I suggest having the Bookmarks UI simply append the option into
the bookmarks listed under each folder when the folder contents are enumerated.
 E.g.:

Bookmarks
.
.
.
Folder 1  ->  Bookmark 1
              Bookmark 2
              Bookmark 3
              --------------------
              Open all in new tabs

I believe that this is something that Multizilla does (although I only looked at
it briefly and I can't recall definitively). But whether it does or not, we
could use that UI design here.  It would mean that the function would be easily
discoverable during normal usage patterns.

BTW: Is anybody aware of the fact that within the Bookmark Manager you can
insert a regular folder (with bookmarks) into a tab group folder?  I just tried
it out of curiosity to see what would happen.  (Wondering how this bug would
treat nested folders...)  While it lets you do it, actually clicking on the tab
group ignores the nested folder.  Shouldn't the Bookmark Manager prevent you
from dragging / pasting / creating a folder inside of a tab group folder?

As one final note: I don't know if this should actually replace the current
bookmark groups so much as augment them.  Consider.  I currently have a bookmark
group that takes up very little UI space in the Bookmarks menu - because it's
only a single icon.  If bookmark groups were removed (to be replaced by regular
folders) then when I ended up selecting the folder it would expand onscreen to
show all of the bookmarks in it.  Seeing a single bookmark group icon is much
"cleaner" visually than seeing a whole lot of individual bookmarks expanded out
from a folder.
I like the idea for an additional "open all" item in the folder's submenu rather
than control-clicking or context menus.
I guess there are much more possible functions than just the open all (e.g. "add
bookmark here", "Delete Bookmark", "Open all Bookmarks in new Windows", "Open
all Bookmarks in new tabs" and so on). However if we add all items to the
bookmarks menu it will become really crowded. So a context menu would be better
(e.g. IE is also using a context menu). 

Another alternative would be an "Actions" item in the bookmark folder that opens
a submenu with all the available actions.
"Open all in new tabs" as applied to folders is sufficient for the moment. 
Other items such as "delete" in context menus need only be applied to bookmarks
themselves, not to folders, and that is covered under bug 50504.

Again, discoverablity of this feature argues against using context menus or
keyboard accelerators.  People already know how to delete bookmarks, they do not
know how to open regular folders as a tab group (or they won't if this feature
hidden).  It's the only special action that warrants being in a submenu outside
of the context menu that should be implemented at some point in parallel to this.
Just out of interest, would using dual menubuttons for bookmark groups on the
personal toolbar be any use?
Blocks: 141227
See also bug 134799, Make any bookmark folder into a bookmark group from folder
properties window.
Nitpick Re comment 17 - To my mind an "open all" submenu makes less sense than a
context menu, as with the context menu we perform something to the BM folder,
rather than delving into it and saying "do something to where we just came from".

I might be wrong, of course...
Try MultiZilla http://multizilla.mozdev.org and see if that works for you. 

You can open any bookmark item, folder or group in tabs or (new) windows. You
can also set any bookmark item, folder or group as your homepage. It will
display the content (bookmarks) for folder, and groupmarks. You can open deep
nested folders inside a groupmark, that is what mozilla's bookmark groups are
called, or just pick one of your favorite bookmarks, so there's no need for
extra (duplicated) bookmarks.
*** Bug 182209 has been marked as a duplicate of this bug. ***
It is not intuitive to have two hierachies mixed together. I have used Mozilla
the last year but never used bookmarkgroups. However I am still missing the
ability to "open all in tabs" for a folder, which is why I shifted to Phoenix. I
strongly support this bug-request, since every browseruser knows how to store
bookmarks in folders. 

This feature "just" adds functionality to a well-known concept instead of
introducing a whole new concept. Since I don't use bookmarkgroups I honestly
don't know if there is any features that could not be realized in the existing
folder-hierarchi.
Why are you commenting on this issue if you don't even use bookmarkgroups? That
makes no sense to me.
I have tried bookmarkgroups obviously, but the concept is too cumbersome
compared to right-clicking on a folder on the sidebar.
Just curious when there could be progress on this enhancement? I recently
switched back to Mozilla from Phoenix for a little while due to stability
issues, and now I realize just how much I enjoyed that feature for my daily
reading sites and webcomics. Adding myself to CC: ...
Why bother making it a context menu at all?

At the moment clicking on a folder on the Bookmarks menu does nothing. Why not
make it open all the bookmarks in that folder? (either in new windows or in new
tabs depending on an "use tabs instead of windows for..." setting) As well as
the setting, "discoverability" could be increased by mentioning on the "New
Folder" and "File This Group of Tabs" dialogs:

Create a new folder named:
__________________________

NOTE: Folders allow you to group related bookmarks. Clicking on a folder opens
all the bookmarks in that folder.
> Why bother making it a context menu at all?

Because this isn't the only bug that a context menu would help solve.  So long
as context menu code gets created for any of the CM related bugs, the rest would
be that much closer to being fixed.

> At the moment clicking on a folder on the Bookmarks menu does nothing.

Nor do I think it should.  A bookmark folder isn't a hyperlink, and left click
on a menu item has never done anything in the past so having it do so now would
not be inuitive.  On the other hand, there is a long history of right-clicking
on items doing something so that's more appropriate. (IMHO.)
Correction.  Left click does do something on some menu items, but not in the
sense of an item that expands itself into other items...
On Mac, clicking on a menuitem with a submenu can have its own action. However,
on Windows and Linux, it always opens the submenu and nothing else, AIUI.
I support comment 9 and comment 14,

and after reading the whole bugs, I'm not sure of the best solution(s),
still I support the idea of unifying both concepts,
with may be properties (like bug 134799) and preferences (about:config) to set
default behaviours.

Since this bug has been opened for more than a year,
I would suggest to add the technical feature now, even if the UI part is not
"easily discoverable" for "new comers";
Once the back-end is working, we could change the front-part as needed.

I have not used v1.5a (based on Firebird !?) yet:
could someone tell what is its current behaviour ? same/different as Mozilla
A.S. up to v1.4(rc1) ?
Product: Browser → Seamonkey
surprised one of the best features in FF has languished so long in suite.
Camino solves this very nicly. A mouse click opens a tab group it in tabs (like
in Seamonkey), click and hold opens it as a folder/menu (like in Firefox). It's
the best of both worlds.

Prog.
(In reply to comment #16)

> Folder 1  ->  Bookmark 1
>               Bookmark 2
>               Bookmark 3
>               --------------------
>               Open all in new tabs

This is just like Firefox. I support this idea.

> I currently have a bookmark
> group that takes up very little UI space in the Bookmarks menu - because it's
> only a single icon. 

So will a folder. Unless you click on that (or hover over it) it is not going to
expand to fill your screen.

> Seeing a single bookmark group icon is much "cleaner" visually than 
> seeing a whole lot of individual bookmarks expanded out from a folder.

I don't think so. At least with a folder and the above-mentioned "Open all as
tabs" menu item, the user has an idea of how many tabs s/he is going to open.
This will make the warning that somebody else proposed "You are opening too many
tabs. This will slow down your PC" message - unnecessary.

I strongly support the idea of bunking bookmark groups in favour of tabs with an
added menu item "Open all as tabs". I don't think "Open all as windows" is
really needed. One of the biggest features of Firefox is tabbed browsing. There
will be little reason for a person to throw three bookmarks into one folder and
not have them open in a single window. (Though that doesn't mean it won't happen.)

In relation to this, I have posted my opinion in bug 156121 that unlike in
Firefox, we should have two separate "Bookmark this tab" and "Bookmark all these
tabs" items. Please see that too.

Adding self to cc list.
(In reply to comment #35)
> Camino solves this very nicly. A mouse click opens a tab group it in tabs (like
> in Seamonkey), click-and-hold opens it as a folder/menu (like in Firefox). It's
> the best of both worlds.

Not any more unfortunately.

Simon, is there any reason why this very useful behavior was removed from
Camino? Was it only to comply with what other browsers (e.g. Safari and Firefox) do?

Prog.
(In reply to comment #37)
> (In reply to comment #35)
> > Camino solves this very nicly. A mouse click opens a tab group it in tabs (like
> > in Seamonkey), click-and-hold opens it as a folder/menu (like in Firefox). It's
> > the best of both worlds.
> 
> Not any more unfortunately.
> 
> Simon, is there any reason why this very useful behavior was removed from
> Camino?

It wasn't; this behavior is still there in Camino (on the bookmarks toolbar).
You're right. The "Tab group" checkbox was unchecked. I've been away for Camino
for too long to miss that ;-)

So, the suggestion stands. I really think SeaMonkey should follow Camino's model
of Bookmark folders and Tab groups. The only thing that might need to be changed
is click-and-hold to open the contained bookmarks in a menu. It works very well,
but is not very common outside MacOS, so right-click may be more appropriate.
Not sure on this one.

Prog.
Assignee: bugs → nobody
QA Contact: claudius → bookmarks
Duplicate of this bug: 371769
Looks like the answer is in bug #371769 comment #1.
Middle-click to open the contents, how's *that* for discoverable, eh? Looks like it conveniently opens the way I want.
A context menu item for this still seems like a good idea though (see below).

Well here's what I had written anyway:

(In reply to comment #18)
> Another alternative would be an "Actions" item in the bookmark folder that
> opens
> a submenu with all the available actions.
Personally, as a user, I would choose a context menu over this (or would I? o.O), but an "Actions" menu could be very helpful to new users.

(In reply to comment #29)
> At the moment clicking on a folder on the Bookmarks menu does nothing.
For the personal toolbar folder (which is where I put _/*ALL*/_ of my bookmarks), clicking is how I start the bookmark browsing process. I also like to drag and drop to make bookmarks. I use the Bookmark Manager to do just that: manage my bookmarks when they need a large dose of management (such as mass deletion).

I have what, 2 bookmark groups in all my bookmarks? Honestly, I don't think it's the most "discovered" feature to begin with. Not to say it isn't useful.

I think bookmark groups should behave as folders, complete with a submenu of it's contents, drag and drop functionality, the works. Just remove bookmark groups and make folders able to open like bookmark groups. Well we can compromise, a bookmark group has a different icon, opens it's contents with a click, and possibly, has a slightly longer delay to show it's submenu contents.

Now, how you handle subfolders when opening in tabs?
Simple: Let me choose.
* A default in the preferences.
* An optional default on the folder.
* Context menu items. (Click on menu for default.)
  Open in new tabs >
    Add tabs >
      Open subfolders
      Don't open subfolders
    Replace tabs >
      Open subfolders
      Don't open subfolders
  Or any which way.
I guess we'll do bug 498596 first.
Depends on: SMPlacesBMarks
Summary: [RFE] Treat bookmark folders as bookmark groups. → Treat bookmark folders as bookmark groups
Fixed by bug 498596 in current nightlies, SeaMonkey 2.1 Alpha 3 and later.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.