Closed Bug 1416284 Opened 3 years ago Closed 3 years ago

What if we dismissed alerts when we hit UnexpectedAlertOpen...

Categories

(Testing :: Marionette, defect)

Version 3
defect
Not set
normal

Tracking

(firefox59 fixed)

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: automatedtester, Assigned: automatedtester)

References

Details

Attachments

(3 files, 2 obsolete files)

This is from a W3C discussion at TPAC.
Assignee: nobody → dburns
Comment on attachment 8927386 [details]
Bug 1416284: Dismiss alerts when we hit an UnexpectedAlertOpen error.

https://reviewboard.mozilla.org/r/198692/#review203904
Attachment #8927386 - Flags: review?(ato) → review+
Comment on attachment 8927435 [details]
Bug 1416284: Update WDSpec tests expectations.

https://reviewboard.mozilla.org/r/198760/#review203906
Attachment #8927435 - Flags: review?(ato) → review+
Attachment #8927435 - Attachment is obsolete: true
Comment on attachment 8927782 [details]
Bug 1416284: Update WDSpec tests expectations.

https://reviewboard.mozilla.org/r/199076/#review204252
Attachment #8927782 - Flags: review?(ato) → review+
Pushed by dburns@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1902e83f331d
Dismiss alerts when we hit an UnexpectedAlertOpen error. r=ato
https://hg.mozilla.org/integration/autoland/rev/b1a9e1788e2e
Update WDSpec tests expectations. r=ato
Backed out two changesets for unexpectedly passing WDSpec tests /webdriver/tests/set_window_rect.py

Backout: https://hg.mozilla.org/integration/autoland/rev/cbb7f77783904f06eadd55ed5010f41f376cbd29

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=b1a9e1788e2e98b81c21280a7014aefea88a026b

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=144415664&repo=autoland&lineNumber=8130

 INFO - TEST-PASS | /webdriver/tests/set_window_rect.py | set_window_rect.py::test_handle_prompt_ignore 
8130
[task 2017-11-13T21:56:01.236Z] 21:56:01     INFO - TEST-UNEXPECTED-PASS | /webdriver/tests/set_window_rect.py | set_window_rect.py::test_handle_prompt_missing_value - expected FAIL
8131
[task 2017-11-13T21:56:01.236Z] 21:56:01     INFO - TEST-INFO | expected FAIL
8132
[task 2017-11-13T21:56:01.239Z] 21:56:01     INFO - 
8133
[task 2017-11-13T21:56:01.240Z] 21:56:01     INFO - TEST-PASS | /webdriver/tests/set_window_rect.py | set_window_rect.py::test_no_change[rect13] 
8134
[task 2017-11-13T21:56:01.240Z] 21:56:01     INFO - TEST-PASS | /webdriver/tests/set_window_rect.py | set_window_rect.py::test_no_change[rect14] 
8135
[task 2017-11-13T21:56:01.245Z] 21:56:01     INFO - TEST-PASS | /webdriver/tests/set_window_rect.py | set_window_rect.py::test_no_change[rect15] 
8136
[task 2017-11-13T21:56:01.245Z] 21:56:01     INFO - TEST-PASS | /webdriver/tests/set_window_rect.py | set_window_rect.py::test_no_change[rect16] 
8137
[task 2017-11-13T21:56:01.245Z] 21:56:01     INFO - TEST-PASS | /webdriver/tests/set_window_rect.py | set_window_rect.py::test_no_change[rect17] 
8138
[task 2017-11-13T21:56:01.245Z] 21:56:01     INFO - TEST-PASS | /webdriver/tests/set_window_rect.py | set_window_rect.py::test_no_change[rect18] 
8139
[task 2017-11-13T21:56:01.245Z] 21:56:01     INFO - TEST-PASS | /webdriver/tests/set_window_rect.py | set_window_rect.py::test_no_change[rect19] 
8140
[task 2017-11-13T21:56:01.245Z] 21:56:01     INFO - TEST-PASS | /webdriver/tests/set_window_rect.py | set_window_rect.py::test_fully_exit_fullscreen 
8141
[task 2017-11-13T21:56:01.245Z] 21:56:01     INFO - TEST-PASS | /webdriver/tests/set_window_rect.py | set_window_rect.py::test_restore_from_minimized 
8142
[task 2017-11-13T21:56:01.245Z] 21:56:01     INFO - TEST-PASS | /webdriver/tests/set_window_rect.py | set_window_rect.py::test_restore_from_maximized 
8143
[task 2017-11-13T21:56:01.245Z] 21:56:01     INFO - TEST-UNEXPECTED-PASS | /webdriver/tests/set_window_rect.py | set_window_rect.py::test_height_width - expected FAIL
8144
[task 2017-11-13T21:56:01.245Z] 21:56:01     INFO - TEST-INFO | expected FAIL
Flags: needinfo?(dburns)
have scheduled a try push but all trees are closed :/
Flags: needinfo?(dburns)
Pushed by dburns@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b1474e3a2e94
Dismiss alerts when we hit an UnexpectedAlertOpen error. r=ato
https://hg.mozilla.org/integration/autoland/rev/dff6393650df
Update WDSpec tests expectations. r=ato
Attachment #8928988 - Attachment is obsolete: true
Pushed by dburns@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ff138177269b
Dismiss alerts when we hit an UnexpectedAlertOpen error. r=ato
https://hg.mozilla.org/integration/autoland/rev/8fc12fbc1422
Update WDSpec tests expectations. r=ato
After hunting down the cause... it was down to the alert loading async and then not waiting for the alert to appear
Flags: needinfo?(dburns)
Backout by nerli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cd4fdff525dc
Backed out 2 changesets for Wd Linux debug failures e.g. in get_window_rect.py r=backout on a CLOSED TREE
Comment on attachment 8930163 [details]
Bug 1416284: Have Wait allow expected exceptions when polling.

https://reviewboard.mozilla.org/r/201314/#review207126

::: testing/web-platform/tests/webdriver/tests/support/wait.py:33
(Diff revision 3)
>          next_interval = max(next_step - time.time(), 0)
>          if not success:
>              time.sleep(next_interval)
>              continue
>          return success
>      raise TimeoutException("Timed out after %d seconds: %s" % (timeout, message))

Use something like `sys.exc_info()` to log what the last exception was for happier debugging.
Attachment #8930163 - Flags: review?(mjzffr) → review-
Comment on attachment 8930163 [details]
Bug 1416284: Have Wait allow expected exceptions when polling.

https://reviewboard.mozilla.org/r/201314/#review207156

::: testing/web-platform/tests/webdriver/tests/support/wait.py:19
(Diff revision 4)
>      :param condition: function that accepts a WebDriver session and returns a boolean
>      :param message: failure description to display in case the timeout is reached
>      :param interval: seconds between each call to `condition`. Default: 0.1
>      :param timeout: seconds until we stop polling. Default: 5
> +    :param ignored_exceptions: Exceptions that are expected and can be ignored.
> +        Default is

Incomplete sentence.

::: testing/web-platform/tests/webdriver/tests/support/wait.py:30
(Diff revision 4)
>      while not (time.time() >= end):
>          next_step = time.time() + interval
> +        try:
> -        success = condition(session)
> +            success = condition(session)
> +        except ignored_exceptions:
> +            print "Last exception encountered was {}".format(sys.exc_info()[0])

We could print this outside of the loop.
Attachment #8930163 - Flags: review?(mjzffr) → review-
Comment on attachment 8930163 [details]
Bug 1416284: Have Wait allow expected exceptions when polling.

https://reviewboard.mozilla.org/r/201314/#review207156

> We could print this outside of the loop.

In case you missed my IRC message: "Could you print the exc_info outside of the loop? e.g. in the except block do `last = sys.exc_info...`, then print `last` right before raising the TimeoutExc..."
Comment on attachment 8930163 [details]
Bug 1416284: Have Wait allow expected exceptions when polling.

https://reviewboard.mozilla.org/r/201314/#review207386
Attachment #8930163 - Flags: review?(mjzffr) → review+
Pushed by dburns@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/35dc4a31d755
Dismiss alerts when we hit an UnexpectedAlertOpen error. r=ato
https://hg.mozilla.org/integration/autoland/rev/572a54e7cbb7
Update WDSpec tests expectations. r=ato
https://hg.mozilla.org/integration/autoland/rev/2541054da0cb
Have Wait allow expected exceptions when polling. r=maja_zf
You need to log in before you can comment on or make changes to this bug.