Closed Bug 1416345 Opened 3 years ago Closed 3 years ago

Expanding user protections on the web using Firefox with pop-up blocker and redirection enhancement

Categories

(Core :: DOM: Navigation, defect, P3)

58 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1406886

People

(Reporter: mp3geek, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [parity-chrome])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171110005445

Steps to reproduce:

Would be good to have something similar to what Chrome announced: https://blog.chromium.org/2017/11/expanding-user-protections-on-web.html

test site: https://ndossougbe.github.io/web-sandbox/interventions/3p-redirect/

* Improve popup blocker
* Preventing Redirection scripts
Component: Untriaged → Document Navigation
Product: Firefox → Core
Epiphany being a linux only Browser has a Native Blocker in it also
Not looking at block lists, more mitigation against redirects and popups (seems most ad servers have a work around the in-browser popup blocker)
Priority: -- → P3
Summary: Expanding user protections on the web using Firefox → Expanding user protections on the web using Firefox with pop-up blocker and redirection enhancement
See Also: → 1411537
CCed Wennie and Ethan to put this on their planning radar!
Whiteboard: [parity-chrome]
Status: UNCONFIRMED → NEW
Ever confirmed: true
Just for reference, Chrome just added better protection for tab-unders, and strengthening the popup blocker;

Detect and block tab-unders: 
     https://bugs.chromium.org/p/chromium/issues/detail?id=661629
Sites with abusive experiences should get a stronger popup blocker:   
     https://bugs.chromium.org/p/chromium/issues/detail?id=756089
Closing this for the more focused Bug 1406886, I'll open another for the abusive popup blocker changes.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1406886
You need to log in before you can comment on or make changes to this bug.