Closed Bug 1416549 Opened 2 years ago Closed 2 years ago

TEST-UNEXPECTED-FAIL | C:\slave\test\build\tests\mozmill\startup-firstrun\test-menubar-collapsed.js | test-menubar-collapsed.js::test_main_menu_collapsed

Categories

(Thunderbird :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 58.0

People

(Reporter: jorgk, Assigned: aceman)

References

Details

(Keywords: regression, Whiteboard: [Thunderbird-testfailure: Z all])

Windows:
TEST-UNEXPECTED-FAIL | C:\slave\test\build\tests\mozmill\startup-firstrun\test-menubar-collapsed.js | test-menubar-collapsed.js::test_main_menu_collapsed

Linux:
TEST-UNEXPECTED-FAIL | /builds/slave/test/build/tests/mozmill/startup-firstrun/test-menubar-collapsed.js | test-menubar-collapsed.js::test_main_menu_collapsed

First seen:
Sun Nov 12, 2017, 1:05:05
https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=c2bfe9667d82e4bf2ea04e07762140dac8a4ed4c

M-C first bad: aabfc14671b55983e1c3053989a4c3b7c5
M-C last good: 57eb0baf17ce8678767abfbf17bdb0acfd

C-C first bad: c2bfe9667d82
C-C last good: 5b6e551a23fb
Flags: needinfo?(acelists)
Thanks, this is caused by bug 1371898, where the setting of autohide=true was removed from mailMigrator.js .
It is also seen in my try run.

If we are expecting to have autohide=true in new profiles, I am wondering why the setting is was in mailMigrator.js and not directly in the XUL file.

I'll see in bug 791311 why this was implemented this way.
Assignee: nobody → acelists
Blocks: 1371898
Status: NEW → ASSIGNED
Flags: needinfo?(acelists)
Keywords: regression
OS: Unspecified → All
Hardware: Unspecified → All
Branch day is tomorrow, so unless a fix here lands today (or bug 1371898 is backed out), this failure will go to beta. I don't know who would handle beta approval and uplifts these days in absence of a Thunderbird release manager.
Thanks for the reminder. Bug 1371898 isn't as critical so I better back it out to better analyze what is going on.
Fixed by backout of bug 1371898
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 58.0
You need to log in before you can comment on or make changes to this bug.