Closed Bug 1416609 Opened 2 years ago Closed 2 years ago

Vertical scrollbar slider invisible on some web sites

Categories

(Core :: Widget: Cocoa, defect)

56 Branch
x86_64
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1408701

People

(Reporter: owenw4rd, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20171024165158

Steps to reproduce:

Open Firefox 56.0.2 (64 bit) in safe mode on a MacBook Pro (Retina, 13-inch, Mid 2014) running macOS High Sierra 10.13.1 (17B48)
Go to example web site: https://forum.davidicke.com/


Actual results:

The web page is vertically scrollable, but the vertical scroll bar is invisible.


Expected results:

Vertical scroll bar should be visible.
This only happens on some web sites.
Doesn't happen on FF running under Windows 10.
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
Summary: Vertical scrollbar missing on some web sites → Vertical scrollbar invisible on some web sites
I found a work-around:

Under System Preferences|General, set Show Scroll Bars: When Scrolling forces the scroll bar to appear after scrolling the mouse wheel or trackpad.

Setting it to Automatic or Always leaves the scroll bar invisible.
That's the default behaviour of macOS apps. As you said, you can/should change it in the system settings.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
No, the scroll bar is visible on the Safari browser when the sysyem scroll bar setting is Always!
Don't be so quick to close the bug. Try to reproduce it first.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Clarification: 

When I said the vertical scroll bar is invisible, I meant the slider. The scroll bar itself was visible, but the slider was invisible.
Okay, I can understand & reproduce the issue now.
Status: UNCONFIRMED → NEW
Component: Untriaged → Widget: Cocoa
Ever confirmed: true
Product: Firefox → Core
Summary: Vertical scrollbar invisible on some web sites → Vertical scrollbar slider invisible on some web sites
Fixed in Firefox 57.
Status: NEW → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1408701
You need to log in before you can comment on or make changes to this bug.