Closed Bug 1408701 Opened 2 years ago Closed 2 years ago

Firefox scrollbar has no thumb on some pages (on macOS 10.13?)

Categories

(Core :: Widget: Cocoa, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox-esr52 --- affected
firefox56 --- wontfix
firefox57 --- verified
firefox58 --- verified

People

(Reporter: cpeterson, Assigned: spohl)

References

()

Details

(Whiteboard: [tpi:+])

Attachments

(2 files)

STR:
1. Load https://blog.zgp.org/
2. Scroll down the page.

RESULT:
Firefox's scrollbar gutter has no "thumb" in Firefox, but it does in Chrome and Safari.

I suspect this is a regression from macOS 10.13. I can reproduce in all Firefox versions I've tested from Nightly 58 back to ESR 52.

I've seen this problem on other pages, but I haven't identified a common pattern.
I'm unable to reproduce this with 10.13.1 Beta 2 (17B35a). Could you post a screenshot?
Flags: needinfo?(cpeterson)
Attached image screenshot.png
Here's a screenshot.
Flags: needinfo?(cpeterson)
Oh, I see. This is with either an external mouse connected or scroll bars set to always display. Markus, have you seen this before?
Flags: needinfo?(mstange)
(In reply to Stephen A Pohl [:spohl] from comment #3)
> Oh, I see. This is with either an external mouse connected or scroll bars
> set to always display.

Yes, I do have "Show scroll bars = Always" enabled. If I reset the system setting to the default "Automatically based on mouse or trackpad", then I can no longer reproduce this bug.
I have not, but I haven't been using 10.13 much.

In the past we've had similar issues when we've disrespected a minimum size requirement. It would be interesting to experiment with different values of macRect in the code that draws the thumb: http://searchfox.org/mozilla-central/rev/a984558fa2bbde6492d3fb918496fc0b0835b2ce/widget/cocoa/nsNativeThemeCocoa.mm#2776-2789

I also noticed that this is a page with a dark background, so we pass kCUIVariantWhite in order to get the white thumb. Maybe that flag has been renamed in 10.13.
Flags: needinfo?(mstange)
Assignee: nobody → spohl.mozilla.bugs
Status: NEW → ASSIGNED
Priority: -- → P1
Whiteboard: [tpi:+]
Attached patch PatchSplinter Review
We should only set white scrollbar thumbs when we're using overlay scrollbars on dark background.

Note: I've tested that switching between overlay and permanent scrollbars with Firefox open works as expected.
Attachment #8919397 - Flags: review?(mstange)
Attachment #8919397 - Flags: review?(mstange) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/dbdf2533a0af54febaf140f09ba4ef1bddeb1161
Bug 1408701: Ensure that we continue to show dark scrollbar thumbs on macOS 10.13 when scrollbars are always displayed. r=mstange
https://hg.mozilla.org/mozilla-central/rev/dbdf2533a0af
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Comment on attachment 8919397 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/Bug causing the regression]: macOS 10.13 regression
[User impact if declined]: Pages with a dark background will fail to show a scrollbar thumb if scrollbars are set to always display.
[Is this code covered by automated tests?]: There is no test specifically for the correct appearance of the scrollbar thumb and it wouldn't be straightforward to add one.
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: Yes. See steps in comment 0.
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: This is a well understood one line change.
[String changes made/needed]: none
Attachment #8919397 - Flags: approval-mozilla-beta?
Comment on attachment 8919397 [details] [diff] [review]
Patch

must fix, beta57+
Attachment #8919397 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Unless we think this is very widespread I don't think we need to fix this for 56.
Flags: qe-verify+
Verified fixed in 57.0b12 and 58.0a1 (id: 20171030100132). Leaving Resolved resolution for ESR as it is still reproducible there.
Duplicate of this bug: 1413611
Duplicate of this bug: 1416609
Duplicate of this bug: 1457866
You need to log in before you can comment on or make changes to this bug.