Closed Bug 1417203 Opened 4 years ago Closed 3 years ago

Very high memory use on Nightly 59 (WebRender?)

Categories

(Core :: Graphics: WebRender, defect, P3)

x86_64
macOS
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox57 --- unaffected

People

(Reporter: yoasif, Unassigned)

References

Details

(Keywords: nightly-community, Whiteboard: [wr-reserve] [gfx-noted])

Attachments

(1 file)

Attached file memory-report.json.gz
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171114100042

Steps to reproduce:

Enabled WebRender: 

– set “gfx.webrender.enabled” to true,
– set “gfx.webrender.blob-images” to true

Use Firefox as normal.


Actual results:

macOS told me that my system had run out of memory. Saved a memory report. macOS reported that Firefox was using 32gb of RAM. 


Expected results:

Firefox should use less memory. 

Application Basics
------------------

Name: Firefox
Version: 59.0a1
Build ID: 20171114100042
Update Channel: nightly
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:59.0) Gecko/20100101 Firefox/59.0
OS: Darwin 16.6.0
Multiprocess Windows: 12/12 (Enabled by default)
Web Content Processes: 4/4
Stylo: content = true (enabled by default), chrome = false (disabled by default)
Google Key: Found
Mozilla Location Service Key: Found
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Nightly Features
----------------

Name: Activity Stream
Version: 2017.11.03.1438-bf427ddd
ID: activity-stream@mozilla.org

Name: Application Update Service Helper
Version: 2.0
ID: aushelper@mozilla.org

Name: Firefox Screenshots
Version: 19.2.0
ID: screenshots@mozilla.org

Name: FlyWeb
Version: 1.0.0
ID: flyweb@mozilla.org

Name: Follow-on Search Telemetry
Version: 0.9.6
ID: followonsearch@mozilla.com

Name: Form Autofill
Version: 1.0
ID: formautofill@mozilla.org

Name: Photon onboarding
Version: 1.0
ID: onboarding@mozilla.org

Name: Pocket
Version: 1.0.5
ID: firefox@getpocket.com

Name: Presentation
Version: 1.0.0
ID: presentation@mozilla.org

Name: Shield Recipe Client
Version: 76.1
ID: shield-recipe-client@mozilla.org

Name: Web Compat
Version: 1.1
ID: webcompat@mozilla.org

Name: WebCompat Reporter
Version: 1.0.0
ID: webcompat-reporter@mozilla.org

Extensions
----------

Name: Containers On The Go
Version: 1.14
Enabled: true
ID: {7e56c1ad-71c3-47fe-bdba-372c7770e0cb}

Name: Firefox Pioneer
Version: 1.0
Enabled: true
ID: pioneer-opt-in@mozilla.org

Name: Gecko Profiler
Version: 0.17
Enabled: true
ID: geckoprofiler@mozilla.com

Graphics
--------

Features
Compositing: WebRender
Asynchronous Pan/Zoom: wheel input enabled; scrollbar drag enabled; keyboard enabled; autoscroll enabled
WebGL 1 Driver WSI Info: CGL
WebGL 1 Driver Renderer: Intel Inc. -- Intel Iris Pro OpenGL Engine
WebGL 1 Driver Version: 4.1 INTEL-10.25.13
WebGL 1 Driver Extensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
WebGL 1 Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
WebGL 2 Driver WSI Info: CGL
WebGL 2 Driver Renderer: Intel Inc. -- Intel Iris Pro OpenGL Engine
WebGL 2 Driver Version: 4.1 INTEL-10.25.13
WebGL 2 Driver Extensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
WebGL 2 Extensions: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context
GPU #1
Active: Yes
Vendor ID: 0x8086
Device ID: 0x0d26

Diagnostics
AzureCanvasAccelerated: 0
AzureCanvasBackend: skia
AzureContentBackend: skia
AzureFallbackCanvasBackend: none
TileHeight: 1024
TileWidth: 1024
Decision Log
WEBRENDER:
opt-in by default: WebRender is an opt-in feature
available by user: Enabled by pref
OMTP:
disabled by default: Disabled by default
blocked by runtime: OMTP does not yet support tiling




Media
-----

Audio Backend: audiounit
Max Channels: 2
Preferred Channel Layout: stereo
Preferred Sample Rate: 44100
Output Devices
Name: Group
Headphones: AppleHDAEngineOutput:1B,0,1,1:0
VX2452 Series: AppleHDAEngineOutputDP:3,0,1,2:0:{635A-DE2E-01010101}
Input Devices
Name: Group
Internal Microphone: AppleHDAEngineInput:1B,0,1,0:1

Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.hashstats_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.frecency_experiment: 1
browser.places.smartBookmarksVersion: 8
browser.search.useDBForOrder: true
browser.sessionstore.upgradeBackup.latestBuildID: 20171114100042
browser.startup.homepage_override.buildID: 20171114100042
browser.startup.homepage_override.mstone: 59.0a1
browser.urlbar.searchSuggestionsChoice: false
browser.urlbar.suggest.searches: false
browser.urlbar.timesBeforeHidingSuggestionsHint: 0
browser.urlbar.usepreloadedtopurls.enabled: false
dom.forms.autocomplete.formautofill: true
extensions.lastAppVersion: 59.0a1
font.internaluseonly.changed: false
gfx.webrender.blob-images: true
gfx.webrender.enabled: true
javascript.options.asyncstack: false
media.gmp-gmpopenh264.abi: x86_64-gcc3
media.gmp-gmpopenh264.lastUpdate: 1508552088
media.gmp-gmpopenh264.version: 1.7.1
media.gmp-manager.buildID: 20171114100042
media.gmp-manager.lastCheck: 1510674699
media.gmp-widevinecdm.abi: x86_64-gcc3
media.gmp-widevinecdm.lastUpdate: 1508182952
media.gmp-widevinecdm.version: 1.4.8.1008
media.gmp.storage.version.observed: 1
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1510676719
places.history.expiration.transient_current_max_pages: 112578
plugin.disable_full_page_plugin_for_types: application/pdf
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_bgcolor: false
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_bgimages: false
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_duplex: -437918235
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_edge_bottom: 0
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_edge_left: 0
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_edge_right: 0
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_edge_top: 0
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_evenpages: true
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_footercenter:
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_footerleft:
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_footerright:
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_headercenter:
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_headerleft:
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_headerright:
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_in_color: true
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_margin_bottom: 0.5
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_margin_left: 0.5
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_margin_right: 0.5
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_margin_top: 0.5
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_oddpages: true
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_orientation: 0
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_page_delay: 50
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_paper_data: 0
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_paper_height: 11.00
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_paper_name: na-letter
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_paper_size_unit: 0
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_paper_width: 8.50
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_resolution: -437918235
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_reversed: false
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_scaling: 1.00
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_shrink_to_fit: true
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_to_file: false
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_unwriteable_margin_bottom: 13
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_unwriteable_margin_left: 13
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_unwriteable_margin_right: 13
print.printer_HP_Officejet_Pro_8620_[NYC]_3.print_unwriteable_margin_top: 13
privacy.trackingprotection.pbmode.enabled: false
privacy.userContext.extension: {7e56c1ad-71c3-47fe-bdba-372c7770e0cb}
security.sandbox.content.tempDirSuffix: {5b19a064-4320-1c43-9f61-ecab545a08da}
services.sync.declinedEngines:
services.sync.engine.addresses.available: true
services.sync.engine.creditcards.available: true
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1508557457

Important Locked Preferences
----------------------------

Places Database
---------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.17
Version in use: 4.17

NSS
Expected minimum version: 3.34 Beta
Version in use: 3.34 Beta

NSSSMIME
Expected minimum version: 3.34 Beta
Version in use: 3.34 Beta

NSSSSL
Expected minimum version: 3.34 Beta
Version in use: 3.34 Beta

NSSUTIL
Expected minimum version: 3.34 Beta
Version in use: 3.34 Beta

Experimental Features
---------------------

Sandbox
-------

Content Process Sandbox Level: 3
Effective Content Process Sandbox Level: 3

Internationalization & Localization
-----------------------------------

Application Settings
Requested Locales: ["en-US"]
Available Locales: ["en-US"]
App Locales: ["en-US"]
Regional Preferences: ["en-US"]
Default Locale: "en-US"
Operating System
System Locales: ["en-US"]
Regional Preferences: ["en-US"]
Component: General → Graphics: WebRender
(In case you scrolled down a Google presentation: bug 1414890.
After today's "I have to like positive Quantum tweets" marathon, my GPU process now takes 5.6 GB RAM + 5.7 GB shared memory.)
Has STR: --- → no
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
Whiteboard: [wr-mvp] [triage]
Whiteboard: [wr-mvp] [triage] → [wr-mvp]
Whiteboard: [wr-mvp] → [wr-mvp] [gfx-noted]
Priority: P2 → P3
Whiteboard: [wr-mvp] [gfx-noted] → [wr-reserve] [gfx-noted]
Do you still run into memory issues? We've fixed a number of issues since this bug was filed.
Flags: needinfo?(yoasif)
It has been a long time, and I have not run into this issue in a while.
Flags: needinfo?(yoasif)
Great!
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.