Closed Bug 1417243 Opened 4 years ago Closed 2 months ago

Flash - Firefox no longer sends mousewheel events via NPP_HandleEvent on Linux or Mac

Categories

(Core :: Plug-ins, defect, P3)

54 Branch
All
macOS
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: jeclark, Unassigned)

References

Details

(Keywords: flashplayer, regression, Whiteboard: [tpi:+])

Attachments

(1 file)

Attached file mousewheel.zip
After Firefox Nightly 54.0a1 2017-02-25, the mouse wheel stopped working on Linux and Mac in Flash Player.  We no longer see mousewheel events through NPP_HandleEvents; however, it's fine on Windows.

From mozregression: 

8:17.89 INFO: No more inbound revisions, bisection finished.
8:17.89 INFO: Last good revision: 973ab774ff18859d5a451a7fe3dc09debed49605
8:17.89 INFO: First bad revision: f065c4ec4ac679d4c80c891592bcbaafa576e6af
8:17.89 INFO: Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=973ab774ff18859d5a451a7fe3dc09debed49605&tochange=f065c4ec4ac679d4c80c891592bcbaafa576e6af

To reproduce: 

Unzip the attached folder and place contents on a webserver
(Recent Firefox versions appear to disallow loading plug-in content from a file:/// URL) 
Run Test.html
Follow the instructions

Expected: 
After moving the mousewheel, you should see PASS - Mouse wheel detected in the result box

Actual: 
An event is never detected, and the result stays at the default value of "FAIL - Mouse Wheel Not Detected"
Blocks: 1342141
Has Regression Range: --- → yes
Component: Untriaged → Plug-ins
Product: Firefox → Core
Hey Stephen, can you please take a look here? This regressed from some work Benjamin did that I approved. Looks like we broke something with mouse wheel events. Hopefully the bug is the same for both platforms.
Flags: needinfo?(spohl.mozilla.bugs)
Priority: -- → P1
Tried reproducing this using Magic Mouse on macOS 10.12, but the test case doesn't detect scroll events using Firefox 53. Will try to reproduce with a traditional mouse with a physical scroll wheel next. If this issue is specific to a particular mouse or macOS version, that would be good to know.

FYI: Local plugin content can be loaded by setting plugins.http_https_only to false in about:config.
Flags: needinfo?(spohl.mozilla.bugs)
Whiteboard: [tpi:+]
Thanks Stephen.  I'll ask someone to triage on older MacOS versions.  FWIW, I'm using a Logitech mouse with the physical scrollwheel to reproduce.
I just tried reproducing with a Logitech MX Master on macOS 10.12.6, Firefox 53.0 and Flash Player 27.0.0.187. Unfortunately, I'm still unable to reproduce this. What version of Flash Player was used to reproduce the issue initially? And are you still able to reproduce this today?
Flags: needinfo?(jeclark)
I'm able to reproduce on MacOS 10.12.6 with Flash Player 27.0.0.187 and 57.0.  Our original reporter ran Mozregression and was able to consistently reproduce it.  Just to be clear, if you click inside the SWF, hover over the circle, and then move the mousewheel, the test should change to say PASS.
Flags: needinfo?(jeclark)
(Firefox 57.0)
I should have been more specific in my earlier comment: I was trying to reproduce the known-good condition in Firefox 53 where the test is reported to show PASS. I have yet to see the test pass in any version of Firefox. Does the test pass for you in Firefox 53?
Flags: needinfo?(jeclark)
Oh, good question.  The bug was originally reported to us by a customer using Ubuntu 16.04.  The QE that triaged it observed that it was also broken on Mac.  I had assumed that they were doing that testing on Mac because I was able to reproduce the failure there.  I had double-checked the testcase against Windows to confirm that it was indeed a valid test.  

They didn't post the mozregression logs, and the QA won't be awake for several more hours, so I'm not 100% clear on the platform they tested on.  I'll see if I can find a passing config on my machines in the meantime.
I was able to confirm the regression range for Ubuntu (54.0a1):

2:40.87 INFO: No more inbound revisions, bisection finished.
22:40.87 INFO: Last good revision: 07fffe40a02399f715612c2cbd22e9ecbcca6e0e
22:40.87 INFO: First bad revision: 9ee6c6f4e59c7967108a727a80e46d686b983a0b
22:40.87 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=07fffe40a02399f715612c2cbd22e9ecbcca6e0e&tochange=9ee6c6f4e59c7967108a727a80e46d686b983a0b

Ancient versions of Firefox (ca. 2009) work on Mac, but I can't get a wide swath of builds to launch from Mozregression.  I'm trying to narrow that down by hand still.
Flags: needinfo?(jeclark)
I think we've conflated two different bugs.  The regression range for Mac is between Firefox 36 and 37.  If you want to consider this one Ubuntu, I'll get our original reporter to track down a tighter regression range.
... and file a new mac bug separately.  :)
(In reply to Jeromie Clark from comment #11)
> ... and file a new mac bug separately.  :)

Yes, let's file two separate bugs in this case. Please CC me on the new bug. Thank you!
Flags: needinfo?(jeclark)
can confirm regression on:

Flash version 27.0.0.187 and 28.0.0.126-1.1_x86_64
FF 57.0-2.1.x86_64
OS: linux 4.11.3-1 x86_64

while it did work on latest ff esr release and does work on current chrome and opera (same host)
Sorry for the delay.  I've been waiting on feedback from the QE assigned to this on our side.

It looks like the Mac regression is much older (pre-2016), and the candidate range doesn't run on newer MacOS builds.  I've sent it back for further investigation, with the recommendation that they test using a corresponding MacOS version.  Hopefully I'll get the additional results soon. 

In the meantime, clearing needsinfo on this bug.  I'll be sure to file the mac issue and copy Stephen when it comes in.
Thanks, Jeromie!
Flags: needinfo?(jeclark)
still occurs
MozillaFirefox-60.0-95.1.x86_64
flash-player-29.0.0.171-1.1.x86_64
Linux linux 4.11.8-2-default
Moving to p3 because no activity for at least 24 weeks.
Priority: P1 → P3
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.