Closed Bug 1417498 Opened 2 years ago Closed 2 years ago

Pushstate navigation handling broken (URL bar and back/forward buttons aren't updated)

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 59
Tracking Status
firefox57 --- unaffected
firefox58 --- verified
firefox59 --- fixed

People

(Reporter: smartfon.reddit, Assigned: JanH)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171112125346

Steps to reproduce:

Place a Nightly 59.0a1 icon on home screen. Open it and visit www.reddit.com and sign in. Then Menu>Page>Add Page Shortcut.
Minimize Nightly and tap on Reddit shortcut to open it through the shortcut this time. Open a thread and let it load. Press the Android Back button.

What it does: minimizes Nightly and shows the home screen.
What it should do: open the previous page, which in this case is the Reddit home page.

Manually open Nightly icon (not the Reddit shortcut). Open any Reddit thread then press Android back button. It properly navigates back to home screen.

Minimize Nightly and open Reddit through the shortcut this time. Repeat the above. It will close the browser instead of opening the previous page after pressing back.

The back button always works properly while the website is opened through the Nightly icon, while never works if the site is opened through the shortcut.
*Manually open Nightly icon (not the Reddit shortcut). Open any Reddit thread then press Android back button. It properly navigates back to home screen.*

I meant "It properly navigates back to website's home page"
It's not specifically related to shortcuts - opening a link to reddit.com in a new tab (so that tab doesn't have an entry for about:home in its history) leads to the same result.
Assignee: nobody → jh+bugzilla
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Unspecified → Android
Hardware: Unspecified → All
Summary: Android Back button closes Nightly instead of opening the previous page if the website is opened from a Shortcut → Pushstate navigation handling broken (URL bar and back/forward buttons aren't updated)
Duplicate of this bug: 1417645
Comment on attachment 8929552 [details]
Bug 1417498 - Account for aRequest being null in onLocationChange.

https://reviewboard.mozilla.org/r/200822/#review207284

Try run passes and this is just adding a null check, r=me
Attachment #8929552 - Flags: review+
Pushed by mozilla@buttercookie.de:
https://hg.mozilla.org/integration/autoland/rev/7ca94f459acf
Account for aRequest being null in onLocationChange. r=JanH
https://hg.mozilla.org/mozilla-central/rev/7ca94f459acf
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Comment on attachment 8929552 [details]
Bug 1417498 - Account for aRequest being null in onLocationChange.

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1410629
[User impact if declined]: URL bar and back/forward button state won't be updated when a page uses the history API
[Is this code covered by automated tests?]: No.
[Has the fix been verified in Nightly?]: Tested locally.
[Needs manual test from QE? If yes, steps to reproduce]: No, but see comment 0 and bug 1417645 for STR just in case.
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: No.
[Why is the change risky/not risky?]: Just adding a null check.
[String changes made/needed]: none
Attachment #8929552 - Flags: review?(s.kaspari) → approval-mozilla-beta?
Comment on attachment 8929552 [details]
Bug 1417498 - Account for aRequest being null in onLocationChange.

Fix a URL bar and back/forward button state broken regression. Beta58+.
Attachment #8929552 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
Verified as fixed on Beta 58.0b7.
Devices:
Samsung Galaxy Tab 3 (Android 7.0)
LG Nexus 5 (Android 6.0.1)
Status: RESOLVED → VERIFIED
Based on comment 11 I will remove the qe-verify flag.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.