Closed Bug 1418181 Opened 5 years ago Closed 5 years ago

WebExtensions running on xml

Categories

(WebExtensions :: General, defect)

58 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1404266

People

(Reporter: u606047, Unassigned)

Details

Attachments

(1 file)

Attached image screenshot.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171115114231

Steps to reproduce:

1.Load any document with Content-Type as text/xml


Actual results:

You will see WebExtension scripts being injected into the page and therefore messing up the xml document preview. This isn't extension specific as far as I can tell because the scripts I saw were from uBlock Origin and minVid(A test pilot addon)


Expected results:

The xml document should be displayed as normal without having additional elements from WebExtension scripts
Component: Untriaged → WebExtensions: General
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1404266
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.