Closed Bug 1418315 Opened 2 years ago Closed 2 years ago

Update webrender to 81cfbcf0763205f25329adb9b2ff75d1cd56e3f1

Categories

(Core :: Graphics: WebRender, enhancement, P1)

59 Branch
enhancement

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: kats, Assigned: kats)

References

(Blocks 1 open bug)

Details

(Whiteboard: [wr-mvp] [gfx-noted])

Attachments

(4 files, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #1417062 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh
Alias: wr-future-update
Blocks: 1391159
No longer blocks: 1391159
WR @ 2ed9b430f6e7d7dbeaf18da264f9ecd86050a988

https://treeherder.mozilla.org/#/jobs?repo=try&revision=d31afd55306f52dec88a9869679d7a3d4b385bbb
https://treeherder.mozilla.org/#/jobs?repo=try&revision=6e1e02feef9ca3f17ae43d1a7ef075a5eda1b608

OS X build bustage.

Regression range:

*   2ed9b430 Auto merge of #2052 - glennw:remove-alpha-task, r=kvark
|\
| * 99b487de Remove AlphaBatchTask, and introduce start of raster mode.
| * f17b7cc1 Make all render task data structs contain a common base field.
* 9ece0436 Auto merge of #2063 - nox:macos-stack, r=nical
* 87eaee28 Update the whole macOS crate stack
 servo/webrender#2063 seems suspect...
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #3)
> WR @ 2ed9b430f6e7d7dbeaf18da264f9ecd86050a988
> 
> https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=d31afd55306f52dec88a9869679d7a3d4b385bbb
> https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=6e1e02feef9ca3f17ae43d1a7ef075a5eda1b608
> 
> OS X build bustage.
> 
> Regression range:
> 
> *   2ed9b430 Auto merge of #2052 - glennw:remove-alpha-task, r=kvark
> |\
> | * 99b487de Remove AlphaBatchTask, and introduce start of raster mode.
> | * f17b7cc1 Make all render task data structs contain a common base field.
> * 9ece0436 Auto merge of #2063 - nox:macos-stack, r=nical
> * 87eaee28 Update the whole macOS crate stack
>  servo/webrender#2063 seems suspect...

Chances are this just needs cargo-update + revendor on the Gecko side.
It needed an update to webrender_bindings/Cargo.toml to use the same version of core-graphics that the rest of webrender now uses. Try pushes with that change:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=9133e989808762ae6223e2740a303289864d7009
https://treeherder.mozilla.org/#/jobs?repo=try&revision=ff337377403e9ca290650ad4a77c4af53eb25324
Assignee: nobody → lsalzman
Status: NEW → ASSIGNED
Priority: P2 → P1
Assignee: lsalzman → nobody
Status: ASSIGNED → NEW
Priority: P1 → P2
WR @ 0864d35c3954da5fe45296c16a46196a7bb42e69

https://treeherder.mozilla.org/#/jobs?repo=try&revision=12ea1df95efd80168e544634587e6c7e20e89453
https://treeherder.mozilla.org/#/jobs?repo=try&revision=7ef27419b131944ca6021b03f53f36defb23a745

Bustage again. Regression range:

*   0864d35c Auto merge of #2050 - kvark:document, r=glennw
|\
| * 07ebcdf2 Document API example Refactor FrameBuilder usage on the RenderBackend side to avoid None Simplified RenderedDocument Fix for building an empty frame Refactored RenderNotifier according to review comments Added an optimization to avoid clearing the whole screen if one of the documents does it
| * 01bf5226 Using the actual target rectangle by the renderer. Naming refactor of RenderedDocument DocumentLayer index for rendering order
| * 39b9065c Multi-doc support on the Renderer side
* 81cfbcf0 Auto merge of #2066 - glennw:checkerboard, r=kvark
* 9e6a9ac3 Add some reftests for perspective interpolation.

Bustage is from servo/webrender#2050. Looks like kvark has some changes to webrender_bindings in the PR, I'll see if that fixes it.
WR @ f0ab6bbb70f01faebbbfd1acbf53c0c68d6391eb

https://treeherder.mozilla.org/#/jobs?repo=try&revision=8afe0c854e5c1d57c518b6ca085a1f5351981429
https://treeherder.mozilla.org/#/jobs?repo=try&revision=b99bf8ec30bea9acd7e8db0c9b6e6fd9ab0136b3

I applied kvark's patch to fix the bustage but we still have a talos test failure caused by a panic in webrender code. Regression range for that is:

*   f0ab6bbb Auto merge of #2070 - glennw:filter-noop, r=nical
|\
| * dfbbf354 Add a simple but important filter optimization.
* |   77531675 Auto merge of #2058 - lsalzman:font-transform, r=lsalzman
|\ \
| |/
|/|
| * f323a313 support font subpixel AA with content transforms
* |   98386269 Auto merge of #2064 - sotaroikeda:rm-lifeparam, r=glennw
|\ \
| * | 01998003 Remove lifetime parameter from Renderer
|  /
* |   b9237e08 Auto merge of #2067 - glennw:error-logs, r=kvark
|\ \
| |/
|/|
| * a93be88e Fix line number error reports from shader compiler.
*   0864d35c Auto merge of #2050 - kvark:document, r=glennw
|\
| * 07ebcdf2 Document API example Refactor FrameBuilder usage on the RenderBackend side to avoid None Simplified RenderedDocument Fix for building an empty frame Refactored RenderNotifier according to review comments Added an optimization to avoid clearing the whole screen if one of the documents does it
| * 01bf5226 Using the actual target rectangle by the renderer. Naming refactor of RenderedDocument DocumentLayer index for rendering order
| * 39b9065c Multi-doc support on the Renderer side
* 81cfbcf0 Auto merge of #2066 - glennw:checkerboard, r=kvark
* 9e6a9ac3 Add some reftests for perspective interpolation.

In the interests of getting a WR update landed I'll do the update to 81cfbcf0 which I expect to be green. Try pushes at that revision:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=22f7baffa92f3ade97e648c7aed41aac725d6465
https://treeherder.mozilla.org/#/jobs?repo=try&revision=02dc6c7dfdcbcb7a7422b70370db0b5a908271d7
Alias: wr-future-update
Assignee: nobody → bugmail
Summary: Future webrender update bug → Update webrender to 81cfbcf0763205f25329adb9b2ff75d1cd56e3f1
Version: unspecified → 59 Branch
Status: NEW → ASSIGNED
Priority: P2 → P1
Comment on attachment 8930237 [details] [diff] [review]
use foreign_types to access CGFontRef from mac NativeFontHandle

Obsoleted by mozreview version
Attachment #8930237 - Attachment is obsolete: true
Comment on attachment 8930522 [details]
Bug 1418315 - Use foreign_types to access CGFontRef from mac NativeFontHandle.

https://reviewboard.mozilla.org/r/201644/#review206934
Attachment #8930522 - Flags: review?(bugmail) → review+
Comment on attachment 8930521 [details]
Bug 1418315 - Update webrender to commit 81cfbcf0763205f25329adb9b2ff75d1cd56e3f1.

https://reviewboard.mozilla.org/r/201642/#review206964
Attachment #8930521 - Flags: review?(nical.bugzilla) → review+
Comment on attachment 8930523 [details]
Bug 1418315 - Update Cargo lockfiles to go with webrender update.

https://reviewboard.mozilla.org/r/201646/#review206966
Attachment #8930523 - Flags: review?(nical.bugzilla) → review+
Comment on attachment 8930524 [details]
Bug 1418315 - Re-vendor third-party rust libraries.

https://reviewboard.mozilla.org/r/201648/#review206968
Attachment #8930524 - Flags: review?(nical.bugzilla) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/931d35586a0f
Update webrender to commit 81cfbcf0763205f25329adb9b2ff75d1cd56e3f1. r=nical
https://hg.mozilla.org/integration/autoland/rev/03300940f434
Use foreign_types to access CGFontRef from mac NativeFontHandle. r=kats
https://hg.mozilla.org/integration/autoland/rev/8d65023108b7
Update Cargo lockfiles to go with webrender update. r=nical
https://hg.mozilla.org/integration/autoland/rev/63a3b5b5b495
Re-vendor third-party rust libraries. r=nical
You need to log in before you can comment on or make changes to this bug.