Update webrender to d490a74c438d987122c600afca6bb2247ab38637

RESOLVED FIXED in Firefox 59

Status

()

defect
P1
normal
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: kats, Assigned: kats)

Tracking

(Blocks 2 bugs)

59 Branch
mozilla59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 fixed)

Details

(Whiteboard: [wr-mvp] [gfx-noted])

Attachments

(3 attachments)

+++ This bug was initially created as a clone of Bug #1416258 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh
Blocks: 1330734
WR @ 6dba5ed000b0c08e507390fff09ef4a134222cf0

https://treeherder.mozilla.org/#/jobs?repo=try&revision=b02fb80cf1be1f4aeeebe22b612c3f5b726b10a9
https://treeherder.mozilla.org/#/jobs?repo=try&revision=c56280ef00884b3e23b4fd877e8ffe484e674a3c

One R6 failure, but that's because I made a mistake with the annotation updating from the last comment. So really this is green.
WR @ 0f95ff027f7e8ca410f3c8d503055189d9f7fb89

https://treeherder.mozilla.org/#/jobs?repo=try&revision=890b09a8417da66616d6a4843d90f9d2f79ef842
https://treeherder.mozilla.org/#/jobs?repo=try&revision=74a44042ba1e7792fcf0a82b68c8eae7fba7a61d

Linux is green, Windows is red :(

Regression range:
* 0f95ff02 Auto merge of #2041 - kvark:query, r=glennw
* 19731c16 GPU queries refactor

Relevant part of the log:

 INFO - WebRender - OpenGL version new OpenGL ES 3.0 (ANGLE 2.1.0.db3422764a9b)
 INFO - ++DOCSHELL 0000028A8F732800 == 1 [pid = 4440] [id = {452f2131-af7f-429d-b62b-5f0e3e6ca998}]
 INFO - ++DOMWINDOW == 1 (0000028A8F733800) [pid = 4440] [serial = 1] [outer = 0000000000000000]
ERROR - thread '<unnamed>' panicked at 'assertion failed: `(left == right)`
 INFO -   left: `Gles`,
 INFO -  right: `Gl`', Z:\build\build\src\gfx\webrender\src\query.rs:76:8
 INFO - stack backtrace:
 INFO -    0:     0x7fffddf48ef1 - <unknown>
 INFO -    1:     0x7fffddf5bd6c - <unknown>
 INFO -    2:     0x7fffddf5ba55 - <unknown>
 INFO -    3:     0x7fffddf5c3f3 - <unknown>
 INFO -    4:     0x7fffddf5c268 - <unknown>
 INFO -    5:     0x7fffddf5c141 - <unknown>
 INFO -    6:     0x7fffde502621 - <unknown>
 INFO -    7:     0x7fffde66ac28 - <unknown>
 INFO -    8:     0x7fffde527ab9 - <unknown>
 INFO -    9:     0x7fffde4e1c8c - <unknown>
 INFO -   10:     0x7fffddf0660b - <unknown>
 INFO -   11:     0x7fffdf983cf6 - mozilla_dump_image
 INFO -   12:     0x7fffdf9841f6 - mozilla_dump_image
 INFO -   13:     0x7fffdf983a49 - mozilla_dump_image
 INFO -   14:     0x7fffdedf9120 - <unknown>
 INFO -   15:     0x7fffdedf2b2e - <unknown>
 INFO -   16:     0x7fffdedf32e1 - <unknown>
 INFO -   17:     0x7fffdedf8ee7 - <unknown>
 INFO -   18:     0x7fffdedf900d - <unknown>
 INFO -   19:     0x7fffdedf8c1d - <unknown>
 INFO -   20:     0x7fffdedfa274 - <unknown>
 INFO -   21:     0x7fffdede4539 - <unknown>
 INFO -   22:     0x7ff810552773 - BaseThreadInitThunk
 INFO - ###!!! [Child][MessageChannel::SendAndWait] Error: Channel error: cannot send/recv
Sorry about that leftover assertion!
Will be fixed by https://github.com/servo/webrender/pull/2049
WR @ 797c0842e07a772aaa2edec7805efe495f57b595

https://treeherder.mozilla.org/#/jobs?repo=try&revision=3c814b6bc5f3f51a6fb2a098cceb8dcd35d369fe
https://treeherder.mozilla.org/#/jobs?repo=try&revision=114935b7dc9efa6076af3f65f457d983a89f07a2

Windows is back to green, yay! However there's a new R7 failure on Linux.

Regression range:

* 797c0842 (HEAD -> master, origin/master, origin/HEAD) Auto merge of #2049 - servo:kvark-query-win, r=jrmuizel
* d8ad962b Query GL assertion removal

An assertion removal seems unlikely to have caused this, but the failure isn't showing up on m-c either. I'm not sure what's going on, will look a bit more.
The R7 failure happened on the previous push as well but I mistakenly thought it was an intermittent. After some more try pushes it looks like this happened as a combination of a gecko-side change and a WR-side change. Pretty sure the WR-side change was servo/webrender#2031, and I'm trying to narrow down the gecko-side change. Regardless I'll probably just mark the reftest failing for the upcoming WR update.
Alias: wr-future-update
Assignee: nobody → bugmail
Summary: Future webrender update bug → Update webrender to d490a74c438d987122c600afca6bb2247ab38637
Version: unspecified → 59 Branch
Comment hidden (mozreview-request)

Comment 14

2 years ago
mozreview-review
Comment on attachment 8929431 [details]
Bug 1417062 - Update webrender to commit d490a74c438d987122c600afca6bb2247ab38637.

https://reviewboard.mozilla.org/r/200750/#review206018

Lots of great stuff in this update!
Attachment #8929431 - Flags: review?(nical.bugzilla) → review+

Comment 15

2 years ago
mozreview-review
Comment on attachment 8929432 [details]
Bug 1417062 - Update reftest annotations for changes in WR PR 2031.

https://reviewboard.mozilla.org/r/200752/#review206020
Attachment #8929432 - Flags: review?(nical.bugzilla) → review+

Comment 16

2 years ago
mozreview-review
Comment on attachment 8929433 [details]
Bug 1417062 - Update for API change in WR PR 2043.

https://reviewboard.mozilla.org/r/200754/#review206022
Attachment #8929433 - Flags: review?(nical.bugzilla) → review+

Comment 17

2 years ago
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c80c224d6b0c
Update webrender to commit d490a74c438d987122c600afca6bb2247ab38637. r=nical
https://hg.mozilla.org/integration/autoland/rev/72cfd88fe0a0
Update reftest annotations for changes in WR PR 2031. r=nical
https://hg.mozilla.org/integration/autoland/rev/cdf4bb1c6af6
Update for API change in WR PR 2043. r=nical
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #9)
> The R7 failure happened on the previous push as well but I mistakenly
> thought it was an intermittent. After some more try pushes it looks like
> this happened as a combination of a gecko-side change and a WR-side change.
> Pretty sure the WR-side change was servo/webrender#2031, and I'm trying to
> narrow down the gecko-side change. Regardless I'll probably just mark the
> reftest failing for the upcoming WR update.

I narrowed down the gecko-side change to https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=07d02e9d114c&tochange=b89090531f6a so it's probably bug 1415407.
Status: NEW → ASSIGNED
Priority: P2 → P1

Comment 19

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/c80c224d6b0c
https://hg.mozilla.org/mozilla-central/rev/72cfd88fe0a0
https://hg.mozilla.org/mozilla-central/rev/cdf4bb1c6af6
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Depends on: 1418813
Depends on: 1424673
You need to log in before you can comment on or make changes to this bug.