https://calibre-ebook.com/ graphic glitch when hovering on the image

RESOLVED FIXED in Firefox 58

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: julienw, Assigned: mattwoodrow)

Tracking

({regression})

Trunk
mozilla59
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox57 unaffected, firefox58 fixed, firefox59+ fixed)

Details

Attachments

(1 attachment)

STR:
1. Go to https://calibre-ebook.com/
2. hover with your mouse on the image in the left
3. put your mouse elsewhere

Expected:
* the image (or its element) is back at its initial size

Actual:
* the image stays on top of the text.

This is new in Nightly, this works as expectded in v58 and v57. It works as expected in Chromium too.


I'll handle the mozregression with my intern.
Cant repro with retain-dl turned off.

2017-11-20T19:38:43: DEBUG : Using url: https://hg.mozilla.org/integration/autoland/json-pushes?changeset=63c91c79579b9992e674ec17b6008432589d0201&full=1
2017-11-20T19:38:44: DEBUG : Found commit message:
Bug 1404181 - Part 27: Add some retained-dl debugging tools. r=mstange

MozReview-Commit-ID: EQO1lAbUnpY

This should block bug 1352499
Flags: needinfo?(matt.woodrow)
After bisecting, we found bug 1416055 to be the culprit -- which confirms comment 1.

2017-11-20T07:54:34: DEBUG : Using url: https://hg.mozilla.org/integration/mozilla-inbound/json-pushes?changeset=d5e1ed773fefe2eb9d52402dd74b5fea19b8b4a4&full=1
2017-11-20T07:54:35: DEBUG : Found commit message:
Bug 1416055 - Enable retained display lists for Nightly builds. r=miko
Blocks: 1352499
Assignee: nobody → matt.woodrow
Flags: needinfo?(matt.woodrow)
Attachment #8930325 - Flags: review?(mikokm)
Comment on attachment 8930325 [details] [diff] [review]
handle-order-changes-correctly-during-merging

Review of attachment 8930325 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Attachment #8930325 - Flags: review?(mikokm) → review+
Tracking since this is a recent regression, and just to make sure the fix lands.
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9f3615964530
Always use the new-list ordering when merging display list since it's guaranteed to be correct. r=miko
https://hg.mozilla.org/mozilla-central/rev/9f3615964530
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Comment on attachment 8930325 [details] [diff] [review]
handle-order-changes-correctly-during-merging

Approval Request Comment
[Feature/Bug causing the regression]: bug 1352499. This is code that is preffed off, but we want to run a shield study enabling the pref.
[User impact if declined]: None, preffed off code.
[Is this code covered by automated tests?]: Yes, when the pref is enabled.
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Code is preffed off.
[String changes made/needed]: None
Attachment #8930325 - Flags: approval-mozilla-beta?
Depends on: 1419869
Comment on attachment 8930325 [details] [diff] [review]
handle-order-changes-correctly-during-merging

Support retain display list shield study. Beta58+.
Attachment #8930325 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Component: General → Layout: Web Painting
We have conflict: warning: conflicts while merging layout/painting/RetainedDisplayListBuilder.cpp! (edit, then use 'hg resolve --mark')
Flags: needinfo?(matt.woodrow)
Flags: needinfo?(matt.woodrow)
You need to log in before you can comment on or make changes to this bug.