[meta] Retain and incrementally update display lists

RESOLVED FIXED

Status

()

enhancement
P1
normal
RESOLVED FIXED
2 years ago
2 months ago

People

(Reporter: mattwoodrow, Assigned: mattwoodrow)

Tracking

(Depends on 8 bugs, Blocks 4 bugs, {meta, perf})

Firefox Tracking Flags

(relnote-firefox 61+)

Details

(Whiteboard: [qf:meta])

Assignee

Description

2 years ago
Rather than building the entire display list each time we paint, we can probably be faster by doing incremental updates to the existing list.

Current plan is here: https://docs.google.com/document/d/1RxUl0z5ViwyAbcQgYvUoorjIQ38M5ZGwwjljBujgE7o/pub
This one's a QF:P1 for Web Painting.
Whiteboard: [qf]
Whiteboard: [qf] → [qf:p1]
Blocks: 1131937
Depends on: 1359584

Updated

2 years ago
See Also: → 1371643
Blocks: 1288096
Depends on: 1382427
Whiteboard: [qf:p1] → [qf:meta]

Updated

2 years ago
See Also: 1371643
Assignee

Updated

2 years ago
Depends on: 1388161
Assignee

Updated

2 years ago
Depends on: 1388162
Assignee

Updated

2 years ago
Depends on: 1388614
Assignee

Updated

2 years ago
Depends on: 1397054
Assignee

Updated

2 years ago
Depends on: 1397056
Assignee

Updated

2 years ago
Depends on: 1397057
Assignee

Updated

2 years ago
Depends on: 1397058
Assignee

Updated

2 years ago
Depends on: 1397059
Assignee

Updated

2 years ago
Depends on: 1397060
Assignee

Updated

2 years ago
Depends on: 1402197
Assignee

Updated

2 years ago
Depends on: 1402199
Assignee

Updated

2 years ago
Depends on: 1402200
Assignee

Updated

2 years ago
Depends on: 1402202
Assignee

Updated

2 years ago
Depends on: 1402203
Assignee

Updated

2 years ago
Depends on: 1402204
Assignee

Updated

2 years ago
Depends on: 1404181
Keywords: perf
Assignee

Updated

2 years ago
Depends on: 1409240

Updated

2 years ago
Depends on: 1411132
Depends on: 1411856
Depends on: 1411876
Assignee

Updated

2 years ago
Depends on: 1411881
Assignee

Updated

2 years ago
Depends on: 1413073
Depends on: 1413546
Depends on: android-rdl
Assignee

Updated

2 years ago
Depends on: 1413833
Depends on: 1414397

Updated

2 years ago
Depends on: 1414526

Updated

2 years ago
Depends on: 1414816

Updated

2 years ago
Depends on: 1415838

Updated

2 years ago
Depends on: 1415869

Updated

2 years ago
Depends on: 1415871
Blocks: 1416026
Assignee

Updated

2 years ago
Depends on: 1416055
Depends on: 1415672
Depends on: 1416065

Updated

2 years ago
Depends on: 1416291
Assignee

Updated

2 years ago
Depends on: 1416448
Depends on: 1417601
Assignee

Updated

2 years ago
Depends on: 1388727
Assignee

Updated

2 years ago
Depends on: 1417529
Assignee

Updated

2 years ago
Depends on: 1417430
Assignee

Updated

2 years ago
Depends on: 1417010
Assignee

Updated

2 years ago
Depends on: 1417411
Assignee

Updated

2 years ago
No longer depends on: 1388727
Assignee

Updated

2 years ago
Depends on: 1418722
Depends on: 1411988
Depends on: 1419021
Depends on: 1418945

Updated

2 years ago
Depends on: 1419225
Assignee

Updated

2 years ago
Depends on: 1419917
Depends on: 1420298
Assignee

Updated

2 years ago
Depends on: 1420312
Assignee

Updated

2 years ago
Depends on: 1418177
Assignee

Updated

2 years ago
Depends on: 1422430
Assignee

Updated

2 years ago
Depends on: 1421954
Blocks: 801949
Assignee

Updated

2 years ago
Depends on: 1419546
Assignee

Updated

2 years ago
Depends on: 1419609

Updated

2 years ago
Depends on: 1420480
Depends on: 1425074
Depends on: 1425115
Assignee

Updated

a year ago
Depends on: 1420737
Assignee

Updated

a year ago
Depends on: 1425271
Assignee

Updated

a year ago
Depends on: 1424348
Assignee

Updated

a year ago
Depends on: 1419315
Assignee

Updated

a year ago
Depends on: 1418840
Depends on: 1425423
Depends on: 1425610
Depends on: 1426044
Assignee

Updated

a year ago
Depends on: 1422274
Assignee

Updated

a year ago
Depends on: RDLPerf
Assignee

Updated

a year ago
No longer blocks: 1288096
Assignee

Updated

a year ago
Depends on: 1427914
Assignee

Updated

a year ago
Depends on: 1427735
Assignee

Updated

a year ago
Depends on: 1427221
Assignee

Updated

a year ago
Depends on: 1425189
Assignee

Updated

a year ago
Depends on: 1428178
Assignee

Updated

a year ago
Depends on: 1427826
Depends on: 1428993
Assignee

Updated

a year ago
Depends on: 1431128
Assignee

Updated

a year ago
Depends on: 1431064
Depends on: 1431209
Assignee

Updated

a year ago
Depends on: 1429027
Assignee

Updated

a year ago
Depends on: 1426348
Depends on: 1433850
Depends on: 1435175
Assignee

Updated

a year ago
Depends on: 1440144
Depends on: 1426345
Depends on: 1448818

Updated

a year ago
Depends on: 1453601
Depends on: 1467514
Assignee

Updated

11 months ago
Priority: -- → P1
Assignee

Updated

9 months ago
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → FIXED
Duplicate of this bug: 884148
You need to log in before you can comment on or make changes to this bug.