Closed Bug 1419230 Opened 2 years ago Closed 2 years ago

Username and password not auto-fill on bualuang.co.th

Categories

(Toolkit :: Password Manager: Site Compatibility, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1147563
Tracking Status
firefox-esr52 --- affected
firefox57 --- affected
firefox58 --- affected
firefox59 --- affected

People

(Reporter: ananuti, Unassigned)

References

()

Details

I have saved username and password for https://www.bualuang.co.th/.

Signon debug:
07:27:12.216 adding <unavailable> to loginFormRootElements for <unavailable>  LoginManagerContent.jsm:1592
07:27:12.222 onDOMFormHasPassword: <unavailable> <unavailable>                LoginManagerContent.jsm:379
07:27:12.225 _detectInsecureFormLikes "https://www.bualuang.co.th/"           LoginManagerContent.jsm:489
07:27:12.482 nsLoginManager:Searching for logins                              nsLoginManager.js:396
07:27:12.504 Login storage:_searchLogins: returning 0 logins for Object { hostname: 
                           "https://www.bualuang.co.th", formSubmitURL: 
                           "https://www.bualuang.co.th" } with options Object { schemeUpgrades: 
                           true }                                             storage-json.js:359
07:27:12.508 LoginManagerParent:sendLoginDataToChild: 0 deduped logins        LoginManagerParent.jsm:220
07:27:12.232 adding <unavailable> to loginFormRootElements for <unavailable>  LoginManagerContent.jsm:1592
07:27:12.257 _detectInsecureFormLikes "https://www.bualuang.co.th/"           LoginManagerContent.jsm:489
07:27:12.484 Invalid chrome URI: /
07:27:12.510 cacheRecipes: for: "https://www.bualuang.co.th"                  LoginRecipes.jsm:207
07:27:12.511 _fillForm <unavailable>                                          LoginManagerContent.jsm:1019
Maybe the form action changed? Or the subdomain?
Component: Password Manager → Password Manager: Site Compatibility
Priority: -- → P3
Looks like the latter, subdomain.

This site has:

> document.getElementById("form_login").action ="https://ent.bualuang.co.th/am/nigol_sw.php";
ok, then you're looking for bug 1147563 and bug 1200472
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
See Also: → 1200472
Duplicate of bug: 1147563

The website is insecure. This should be the reason why the credentials aren't auto-filled. I am looking for confirmation, if possible. If it should auto-fill, then it should be fixed by the change done for its duplicate.

Flags: needinfo?(MattN+bmo)

Where do you see that it's insecure? When I visit the site over https: I don't see errors.

The fix for bug 1147563 doesn't affect autofill, it only affects autocomplete.

Flags: needinfo?(MattN+bmo)
You need to log in before you can comment on or make changes to this bug.