Closed Bug 1420166 Opened 2 years ago Closed 2 years ago

regression: context menu on about:config has lost its style

Categories

(Toolkit :: XUL Widgets, defect)

59 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla59
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- fixed

People

(Reporter: darkspirit, Assigned: bgrins)

References

()

Details

(Keywords: nightly-community, regression)

Attachments

(2 files)

Nightly 59 x64 20171123100420 de_DE b6bed1b710c3e22cab49f22f1b5f44d80286bcb9 @ Debian Testing (KDE, Radeon RX480)
fresh profile

1. open about:config
2. click the blue "I accept the risk!" button
3. do a rightclick

See attached screenshot.

mozregression --good 2017-11-22 --bad 2017-11-23
> 3:35.81 INFO: Last good revision: 87368e9f8bada46d65cd3d78984ad14e152a5e60
> 3:35.81 INFO: First bad revision: 5f57907f645bf30a72e0dd0a7013054fe328a3ce
> 3:35.81 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=87368e9f8bada46d65cd3d78984ad14e152a5e60&tochange=5f57907f645bf30a72e0dd0a7013054fe328a3ce

> 5f57907f645b	Brian Grinstead — Bug 1416493 - Remove the menuseparator XBL binding;r=Gijs
Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(bgrinstead)
Does this also happen on about:preferences with e.g. context menus in the textboxes?
I guess it's not loading global.css: https://dxr.mozilla.org/mozilla-central/source/toolkit/components/viewconfig/content/config.xul. Is there a reason to not load global.css for about:config?

Based on the comment at the top of global.css (https://dxr.mozilla.org/mozilla-central/source/toolkit/themes/linux/global/global.css#5-7) I assumed it would be loaded in all XUL documents:

/* ===== global.css =====================================================
  == Styles that apply everywhere.
  ======================================================================= */
FWIW it looks like this is the only xul doc loading `chrome://global/skin/in-content/info-pages.css`: https://dxr.mozilla.org/mozilla-central/search?q=chrome%3A%2F%2Fglobal%2Fskin%2Fin-content%2Finfo-pages.css&redirect=true
(In reply to :Gijs from comment #1)
> Does this also happen on about:preferences with e.g. context menus in the textboxes?

No, it seems to be fine there. (about:preferences#general > Settings search, Home page, file types)
Pushed up a change with a reference to global.css.  This does make me wonder if we should be loading that file automatically in xul documents similar to xul.css (and maybe there's also a perf win to be had: https://dxr.mozilla.org/mozilla-central/source/layout/style/nsLayoutStylesheetCache.cpp#355-359)
Flags: needinfo?(bgrinstead)
(In reply to Brian Grinstead [:bgrins] from comment #6)
> Pushed up a change with a reference to global.css.  This does make me wonder
> if we should be loading that file automatically in xul documents similar to
> xul.css (and maybe there's also a perf win to be had:
> https://dxr.mozilla.org/mozilla-central/source/layout/style/
> nsLayoutStylesheetCache.cpp#355-359)

Wanna file an exploratory perf bug to look into that? :)
(In reply to :Gijs from comment #8)
> Wanna file an exploratory perf bug to look into that? :)

Sure, setting needinfo to remind myself to do that next week
Flags: needinfo?(bgrinstead)
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Comment on attachment 8931400 [details]
Bug 1420166 - Include global.css on about:config;

https://reviewboard.mozilla.org/r/202534/#review207912

Nice and simple, rs=me
Attachment #8931400 - Flags: review?(gijskruitbosch+bugs) → review+
Pushed by bgrinstead@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/be5e92dc51ec
Include global.css on about:config;r=Gijs
https://hg.mozilla.org/mozilla-central/rev/be5e92dc51ec
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Duplicate of this bug: 1420370
(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #0)
> Nightly 59 x64 20171123100420 de_DE b6bed1b710c3e22cab49f22f1b5f44d80286bcb9 @ Debian Testing (KDE, Radeon RX480)

Verified fixed in Nightly 59 x64 20171124100500 de_DE f2e36fbb90fad27c034105709a4cbbaef9bd58c8 @ Debian Testing (KDE).
Status: RESOLVED → VERIFIED
I see this issue in Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0 ID:20171123220110, and Verified fixed in Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0 ID:20171124220317.
OS: Linux → All
Hardware: x86_64 → All
See Also: → 1471667
(In reply to Brian Grinstead [:bgrins] from comment #9)
> (In reply to :Gijs from comment #8)
> > Wanna file an exploratory perf bug to look into that? :)
> 
> Sure, setting needinfo to remind myself to do that next week

Following up on this - I think we won't want to load a document sheet in the style cache as per https://bugzilla.mozilla.org/show_bug.cgi?id=1470842#c6.
Flags: needinfo?(bgrinstead)
You need to log in before you can comment on or make changes to this bug.