GTK3 Mint-Y Theme window buttons are not rendered properly

RESOLVED DUPLICATE of bug 1408335

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1408335
a year ago
a year ago

People

(Reporter: reinhart_previano, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171124151312

Steps to reproduce:

1. Set Mint-Y as the default theme for GTK3 windows.
*Mint-Y is one of the default themes in Linux Mint 18, so you may wish to test this in Linux Mint AND Cinnamon before using the theme in other Linux distros and desktop environments.
2. Restart Firefox.
3. Go to Menu > Customize, and make sure that the "Title Bar" option is unchecked.


Actual results:

The window control buttons (i.e. Close, Maximize and Minimize buttons) have a weird shadow unlike in other windows. Even worse, these buttons are not shown when a custom theme is applied (or changing the theme to other than 'Default').


Expected results:

The buttons should be rendered properly as with other GTK3 themes, such as Adapta and Adwaita.
(Reporter)

Updated

a year ago
Component: Untriaged → Theme
Blocks: gtktitlebar
Component: Theme → Widget: Gtk
Product: Firefox → Core

Comment 2

a year ago
Probably a duplicate of [1408335](https://bugzilla.mozilla.org/show_bug.cgi?id=1408335)
Priority: -- → P3
Can you please check if Bug 1408335 fixes that for you? It should be in latest nightly already.
Flags: needinfo?(reinhart_previano)
(Reporter)

Comment 4

a year ago
Posted image Fixed.png
So far, the bug is fixed, even though small details such as window corners are not present. However, when applying the Firefox's Light theme, there is a white bar at the top of the tab selection. Is that intentional?
Flags: needinfo?(reinhart_previano)
(Reporter)

Comment 5

a year ago
Posted image Fixed-2.png
Here's what the browser look like in Elementary OS (with OSX-Arc theme and window buttons tweaked to mimic macOS). Is there a bug related with matching the window control buttons with GTK (Cinnamon, GNOME, Unity, XFCE and forks), QT (KDE and LXQT) as well as Openbox (LXDE) order?
Controls are covered by Bug 1419442. The white strip does not have a bug yet but should be also partially fixed by Bug 1419442.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1408335
You need to log in before you can comment on or make changes to this bug.