[CSD] Wrong titlebar button icons on some themes

RESOLVED FIXED in Firefox 60

Status

()

defect
P2
normal
RESOLVED FIXED
2 years ago
Last year

People

(Reporter: stransky, Assigned: stransky)

Tracking

(Blocks 2 bugs)

Trunk
mozilla60
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox58 wontfix, firefox59 wontfix, firefox60 fixed)

Details

Attachments

(1 attachment)

Follow up from Bug 1399611 comment 15:

Hi all,
I am testing the CSD patch on Debian via flatpak. It works quite well except for the fact that superimposed to my icon theme buttons (close and maximize, minimize if present)there is another set of gray icons. Changing the theme, my icons change but the superimposed ones persist. I can't figure out if it is a Flatpak issue or it's due to the program itself.
Assignee

Comment 1

2 years ago
I noticed that that LWT themes in Windows (I tested W10) also provide icons - we should also implement that for Linux.
Assignee

Updated

2 years ago
Blocks: gtktitlebar
No longer blocks: 1399611

Comment 2

2 years ago
Not sure if this warrants a separate ticket:

Just tried CSD in latest nightly and so far it's great! I did notice the close button is slightly off when using the popular Arc Gtk theme https://github.com/horst3180/arc-theme

Close button is not centred and fill is the wrong colour.

See https://imgur.com/a/raeCR for screenshot comparison of densities

Comment 3

2 years ago
Running KDE neon as the distro here, which basically is the official KDE distro and is always up-to-date with the latest KDE software: https://neon.kde.org/

KDE neon is currently based on Ubuntu 16.04, which uses GTK+ 3.18. This is what it looks like here:

https://bugzilla.mozilla.org/attachment.cgi?id=8929825

As you can see, the window controls in the tab bar look odd, which probably is: https://bugzilla.mozilla.org/show_bug.cgi?id=1408335

The other issues like the duplicated window controls and so on are being tracked in: https://bugzilla.mozilla.org/show_bug.cgi?id=1417933

Comment 4

2 years ago
(In reply to Michael Heyns from comment #2)
> Not sure if this warrants a separate ticket:
> 
> Just tried CSD in latest nightly and so far it's great! I did notice the
> close button is slightly off when using the popular Arc Gtk theme
> https://github.com/horst3180/arc-theme
> 
> Close button is not centred and fill is the wrong colour.
> 
> See https://imgur.com/a/raeCR for screenshot comparison of densities

I can confirm this behaviour. To expand on it:

Here's what it looks like with minimize and maximize buttons: https://imgur.com/a/nlng4
There appears to be a second set of buttons on top of the regular Arc Theme buttons, like described in comment #0.

It appears, this issue is present throughout all GTK+ themes I have installed, including Adwaita(-dark), Adapta, Numix-frost and Paper.

Using Nightly (20171120)

Comment 5

2 years ago
I'm also seeing that behavior. See attached images.

https://imgur.com/a/lEWvE

This is 59.0a1 (2017-11-22) (64-bit). Thanks a bunch!
Assignee

Updated

2 years ago
Summary: [CSD] Wrong button rendering on some themes → [CSD] Wrong titlebar button icons on some themes
Assignee

Updated

2 years ago
Assignee: nobody → stransky
Assignee

Updated

2 years ago
Priority: P3 → P2
Assignee

Comment 6

2 years ago
It's caused by Gtk+ themes with a specific button.titlebutton theming.

For instance Arc-Dark defines:

.titlebar button.titlebutton.close,
.titlebar button.titlebutton.maximize,
.titlebar button.titlebutton.minimize {
    color: transparent;
    ....
}

.titlebar button.titlebutton.close {
 background-image: -gtk-scaled(url("assets/titlebutton-close-dark.png"), url("assets/titlebutton-close-dark@2.png")); }

which means default Gtk+ titlebar button is transparent (invisible) and it's completely replaced by background-image.
Assignee

Updated

2 years ago
Depends on: 1427999
Comment hidden (mozreview-request)
Assignee

Updated

Last year
Blocks: 1424422
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Assignee

Updated

Last year
Blocks: 1433068
Assignee

Updated

Last year
Duplicate of this bug: 1424158

Comment 11

Last year
mozreview-review
Comment on attachment 8941009 [details]
Bug 1408335 - Render titlebar icons as themed ones,

https://reviewboard.mozilla.org/r/211298/#review222310

::: widget/gtk/gtkdrawing.h:313
(Diff revision 3)
>    MOZ_GTK_SCROLLED_WINDOW,
>    /* Paints a GtkHeaderBar */
>    MOZ_GTK_HEADER_BAR,
>    /* Paints a GtkHeaderBar in maximized state */
>    MOZ_GTK_HEADER_BAR_MAXIMIZED,
>    /* Paints GtkHeaderBar title buttons */

Please add comment that you expect TOOLBAR_BUTTONS number of buttons starting with MOZ_GTK_HEADER_BAR_BUTTON_CLOSE (because you use this value as starting point for pointer to array of buttons cache).
Attachment #8941009 - Flags: review?(jhorak) → review+
Comment hidden (mozreview-request)

Comment 13

Last year
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/8fbf1c39eb3b
Render titlebar icons as themed ones, r=jhorak
https://hg.mozilla.org/mozilla-central/rev/8fbf1c39eb3b
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Assignee

Updated

Last year
Duplicate of this bug: 1420938

Comment 16

Last year
There appears to be a regression of this bug, in build 20180303100406
Window buttons look like they did, before bug 1408335 was fixed.

Comment 17

Last year
I can confirm that there is a regression that appeared y-day or the day before.
(In reply to Bruno Pagani from comment #17)
> I can confirm that there is a regression that appeared y-day or the day
> before.

Can you please file another bug for that, attach a screenshot and specify which theme do you run. Thanks!
Flags: needinfo?(bruno.n.pagani)

Comment 19

Last year
(In reply to Martin Stránský [:stransky] from comment #18)
> (In reply to Bruno Pagani from comment #17)
> > I can confirm that there is a regression that appeared y-day or the day
> > before.
> 
> Can you please file another bug for that, attach a screenshot and specify
> which theme do you run. Thanks!

Done: https://bugzilla.mozilla.org/show_bug.cgi?id=1443481
Flags: needinfo?(bruno.n.pagani)
Assignee

Updated

Last year
Duplicate of this bug: 1439311
Comment hidden (spam)
You need to log in before you can comment on or make changes to this bug.