Closed Bug 1421048 Opened 2 years ago Closed 2 years ago

Update pdf.js to version 2.0.161

Categories

(Firefox :: PDF Viewer, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 59
Tracking Status
firefox59 --- fixed

People

(Reporter: RyanVM, Assigned: RyanVM)

References

Details

+++ This bug was initially created as a clone of Bug #1418041 +++

Changes since last update:
#9131 Filling and stroking empty paths in SVG backend
#9126 Extract parsing of debugging hash parameters into its own method in `PDFViewerApplication`
#9122 Remove mentions of compatibility.js from examples
#9073 Fix the interface of `JpegStream`/`JpxStream`/`Jbig2Stream` to agree with the other `DecodeStream`s
#9156 Update README.md
#9037 Re-factor how parameters are passed to the network streams
#9157 Update index.md
#9140 Remove the `console` polyfills
#9158 Sanitize the display value for choice widget annotations
#9162 Update index.md
#9179 Add mgol's name to AUTHORS, add .mailmap
#9170 Remove more polyfills for old browsers
#9182 Don't display error messages, in the default viewer, for PDF files other than the current one
#9187 Update eslint-plugin-mozilla, and enable mozilla/use-services rule.
#9095 Split the existing `WebGLUtils` in two classes, a private `WebGLUtils` and a public `WebGLContext`, and utilize the latter in the API to allow various code to access the methods of `WebGLUtils`
#9189 Remove the unused `capability` parameter from the `WorkerTransport.getPage` method
#9190 Remove the `pageRotation` getter in `PDFViewerApplication`
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/cb4618e15399
Update pdf.js to version 2.0.161. r=bdahl
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7533d1ac4e7a
Re-apply ESLint fixes that never got upstreamed. r=me
(In reply to Pulsebot from comment #2)

This was caused by bug 1408777 and bug 1367704 making changes that weren't upstreamed. Jonas, can I talk you into making the same change upstream to avoid future bustage? I've already left a note in bug 1367704 about being more careful to do the same for future ESLint mass changes.
Flags: needinfo?(jonas.jenwald)
(In reply to Ryan VanderMeulen [:RyanVM] from comment #3)
> (In reply to Pulsebot from comment #2)
> 
> This was caused by bug 1408777 and bug 1367704 making changes that weren't
> upstreamed. Jonas, can I talk you into making the same change upstream to
> avoid future bustage? I've already left a note in bug 1367704 about being
> more careful to do the same for future ESLint mass changes.

Unfortunately it's not so easy in this case, since the code in question is actually being inserted using the (old) pre-processor; please refer to e.g. https://github.com/mozilla/pdf.js/blob/3e34eb31d940f5e8add0af5ee9b262c9f3ad1462/extensions/firefox/content/PdfJs.jsm#L82-L86

Obviously we could either try to fix the old pre-processor, or perhaps use Webpack for this part of PDF.js too. However, with the uncertain future of PDF.js in Firefox (w.r.t. project Mortar, whatever its status is nowadays), I personally don't feel very motivated to work on this. Sorry about that!
Flags: needinfo?(jonas.jenwald)
FWIW, I don't expect Mortar to happen in any appreciable way any time soon yet.

Brendan, any thoughts on how to proceed?
Flags: needinfo?(bdahl)
https://hg.mozilla.org/mozilla-central/rev/cb4618e15399
https://hg.mozilla.org/mozilla-central/rev/7533d1ac4e7a
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Blocks: 1421987
(In reply to Ryan VanderMeulen [:RyanVM] from comment #5)
> FWIW, I don't expect Mortar to happen in any appreciable way any time soon
> yet.
> 
> Brendan, any thoughts on how to proceed?

Should be fixed upstream now
https://github.com/mozilla/pdf.js/pull/9244
Flags: needinfo?(bdahl)
You need to log in before you can comment on or make changes to this bug.