Closed Bug 1421874 Opened 4 years ago Closed 4 years ago

Error: "ReferenceError: AppConstants is not defined" in SessionStore.js

Categories

(Toolkit :: Crash Reporting, defect)

59 Branch
All
Android
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- fixed

People

(Reporter: jchen, Assigned: gsvelto)

References

Details

Attachments

(1 file)

Lots of these errors in the Fennec logs,

> GeckoConsole: [JavaScript Error: "ReferenceError: AppConstants is not defined" {file: "jar:jar:file:///data/app/org.mozilla.fennec_aurora-1.apk!/assets/omni.ja!/components/SessionStore.js" line: 1242}]

I think we need to import AppConstants.jsm
Flags: needinfo?(gsvelto)
Duplicate of this bug: 1422291
Hardware: Unspecified → All
Version: unspecified → 59 Branch
Yes, I missed it in bug 1402519, sorry about that.
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
Flags: needinfo?(gsvelto)
Comment on attachment 8933634 [details]
Bug 1421874 - Fix SessionStore to include AppConstants before using it;

https://reviewboard.mozilla.org/r/204578/#review210166
Attachment #8933634 - Flags: review?(s.kaspari) → review+
Pushed by gsvelto@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/733552921142
Fix SessionStore to include AppConstants before using it; r=sebastian
https://hg.mozilla.org/mozilla-central/rev/733552921142
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
You need to log in before you can comment on or make changes to this bug.