ReferenceError: AppConstants is not defined (SessionStore.js line: 1242)

RESOLVED DUPLICATE of bug 1421874

Status

()

Firefox for Android
Session Restore
P1
normal
RESOLVED DUPLICATE of bug 1421874
2 months ago
a month ago

People

(Reporter: JanH, Unassigned)

Tracking

({regression})

Firefox 59
All
Android
regression
Points:
---

Firefox Tracking Flags

(firefox57 unaffected, firefox58 unaffected, firefox59 fixed)

Details

(Reporter)

Description

2 months ago
Saw this line in some Robocop test logs:
> 11-30 10:40:52.583  2709  2725 E GeckoConsole: [JavaScript Error: "ReferenceError: AppConstants is not defined" {file: "jar:jar:file:///data/app/org.mozilla.fennec_aurora-1.apk!/assets/omni.ja!/components/SessionStore.js" line: 1242}]

Apart from breaking the crash reporter URL annotation itself, this also has the potential to mess up other session store stuff, although luckily _updateCrashReportURL is usually called near the end of our session store event handlers so it seems that nothing major is broken, although there could be some edge cases.
Flags: needinfo?(gsvelto)
(Reporter)

Comment 1

2 months ago
Never mind, jchen spotted it first.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Flags: needinfo?(gsvelto)
Resolution: --- → DUPLICATE
Duplicate of bug: 1421874
Fixed in Bug 1421874.
status-firefox59: affected → fixed
You need to log in before you can comment on or make changes to this bug.