URL autocomplete should try to match the shortest match instead of the longest match

RESOLVED DUPLICATE of bug 96700

Status

SeaMonkey
Location Bar
RESOLVED DUPLICATE of bug 96700
16 years ago
9 years ago

People

(Reporter: Krishnakumar B, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0+) Gecko/20020501
BuildID:    2002050121

The URL autocomplete function tries to match the longest/most recent term. But
this gives bogus behaviour. Suppose you have a list of URLs in history, starting
with say:

ftp://ftp.crc.ca/pub
ftp://ftp.crc.ca/pub/systems/
ftp://ftp.crc.ca/pub/systems/Linux/
ftp://ftp.crc.ca/pub/systems/Linux/by-site/

Now try to type in ftp://ftp.crc.ca. The autocomplete should show the shortest
match i.e ftp://ftp.crc.ca/pub and not
ftp://ftp.crc.ca/pub/systems/Linux/by-site/ which is the most-recent history
information. The reason is simple. Many times I go multiple levels deep into a
web-site's hierarchy and later want to go to either the web-site's main page or
some level in the middle. This is not possible currently. As soon as I type
ftp://ftp.crc.ca/pub, I get the longest URL autocompleted which results in
lossage like pressing the delete key to delete the selected portion beyond which
I don't want autocompleted and then pressing enter or typing the remaining
portion of the URL.

If this is the intended behaviour, I suggest giving an option to control the
order of match (This is getting geekier than I thought because of the weird
behaviour given by the default autocomplete...so much for UI friendliness).

FWIW, IE does the expected autocomplete i.e try to match the shortest URL
available (which matches the portion of URL entered till then) and then
completes to longer URLs, when prompted by typing more characters.

Reproducible: Always
Steps to Reproduce:
1. Visit any ftp site which results in a history with one-directory   variations. 
2. Try to visit the site's main page later by entering portion of the URL. 
3. 

Actual Results:  Watch the autocomplete irritate you to the core by returning
the longest match in history.

Expected Results:  Autocomplete should only autocomplete till the shortest URL
history in and wait for further prodding from the user.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

16 years ago
How does this bug interact with bug 141491?

Comment 2

16 years ago
Well, if you hadn't done this before I would have filed this bug because I think
the behaviour is somewhat annoying. (I'll turn autocomplete off after posting this.)
You got my vote.

And please change OS to all, I'm using Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.1b) Gecko/20020721 Build ID: 2002072104 and got the same behaviour.

Updated

15 years ago
OS: Linux → All

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 96700 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.