[Firefox beta] toolkit.telemetry.enabled is locked and can not be disabled

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: aris-addons, Unassigned)

Tracking

58 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171130160223

Steps to reproduce:

about:config > toolkit.telemetry.enabled


Actual results:

'toolkit.telemetry.enabled' was locked and set to true.


Expected results:

'toolkit.telemetry.enabled' should not be locked on "beta" channel (only one developer and nightly channel). Users should be able to set it to false.
Component: Untriaged → Telemetry
Product: Firefox → Toolkit
On Firefox Desktop starting with 58 toolkit.telemetry.enabled is locked to "true" on beta, aurora, and nightly channels (as well as unofficial builds with the 'default' channel). It is locked to "false" in all other cases.

This, rather unstraighforwardly, does not mean Telemetry is enabled. This means that, if telemetry is enabled, we collect somewhat more information. More details about our unfortunately-confusing Telemetry preferences can be found in the docs[1] and in the bug tree rooted at bug 1406390.

To disable Telemetry, uncheck the box in about:preferences labelled "Allow Firefox to send technical and interaction data to Mozilla". That will disable all data collection from Firefox to Mozilla via Telemetry. The corresponding about:config pref is `datareporting.healthreport.uploadEnabled`

We plan on straightening out the confusion caused by these historical naming artefacts next year.

[1]: https://firefox-source-docs.mozilla.org/toolkit/components/telemetry/telemetry/internals/preferences.html
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.