Closed Bug 1422692 Opened 2 years ago Closed 2 years ago

Credit card - Clear Form dropdown is not displayed on "Expiration" field

Categories

(Toolkit :: Form Autofill, defect, major)

defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla59
Tracking Status
firefox59 --- verified

People

(Reporter: Ovidiu, Assigned: ralin)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

[Affected versions]:

Tested on Nightly 59.0a1(2017-12-03)

[Affected platforms]:

Tested on Mac OS X 10.13

[Steps to reproduce]:

Prerequisites:
 1. Make sure you have at least two saved profile.
 2. Create a PayPal account
 
1. Go to https://www.paypal.com/myaccount/wallet/add/card
2. Click on the "Expiration" field and select a profile, fill in.
3. Click again on the "Expiration" field.


[Expected result]:

A drop down with 2 buttons is shown. 

[Actual result]:

The dropdown is not displayed. 

NOTE: please see this video for a better understanding https://streamable.com/0nu96
Blocks: 1404768
I verified this issue on Windows 10 X 64 using Nightly 59.0a1 and during the investigation, I found that if I want to change the billing address and I am clicking on the address field to add another address, the website is redirecting to another page where the autofill suggestions are not displayed.
Assignee: nobody → ralin
See Also: → 1422745
Status: NEW → ASSIGNED
Comment on attachment 8934403 [details]
Bug 1422692 - Make search result always return success code for every filled fields to show clear form button popup.

https://reviewboard.mozilla.org/r/205324/#review210918

Thanks for addressing this.
Attachment #8934403 - Flags: review?(lchang) → review+
Pushed by ralin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9a3c724da72a
Make search result always return success code for every filled fields to show clear form button popup. r=lchang
https://hg.mozilla.org/mozilla-central/rev/9a3c724da72a
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
I verified this issue on Mac OS X 10.13, Windows 7 and 10 with FF Nightly 59.0a1(2017-12-06) and I can confirm the fix, the issue is no longer reproducible.
Status: RESOLVED → VERIFIED
We tested on Mac OS X 10.11 and we saw an issue, please see the video: https://streamable.com/4tg1z and tell us if we need to log another bug specific for Mac OS X 10.11(only on this OS the issue is reproducible) or reopen this one? Thanks
Flags: needinfo?(ralin)
Update: The issue that was initially reported it's fixed and I can't reproduce it. 
The issue from comment 9 is a new one, I think it's introduced by this fix, and we can reproduce it on Windows Ubuntu and Mac, here is the video that describes the issue:  https://streamable.com/4tg1z. I think we have a new bug. Please tell me your opinion.
Hi Ovidiu,

Yeah, I think it's a new one. Could you file another bug for tracking? Thanks.
Flags: needinfo?(ovidiu.boca)
Hi Luke,

I logged bug 1424174 for tracking the issue from comment 10. Thanks
Flags: needinfo?(ovidiu.boca)
clear NI, thank you Luke!
Flags: needinfo?(ralin)
You need to log in before you can comment on or make changes to this bug.