[NIGHTLY 59] On Linux option to Hide Titlebar works -- But makes browser window buttons hard to see, and completely disappear on Light and Dark theme.

RESOLVED DUPLICATE of bug 1424422

Status

()

defect
P3
trivial
RESOLVED DUPLICATE of bug 1424422
a year ago
a year ago

People

(Reporter: mklltech, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171130143349

Steps to reproduce:

Hamburger Menu >> Customize Firefox >> Hide Titlebar.


Actual results:

Window controls turned very light gray from the usual darker gray with the titlebar active. When switching to dark theme or light theme the window controls are invisible.


Expected results:

Window controls should stay visible like they were before disabling the titlebar.
(Reporter)

Comment 1

a year ago
Posted image titlebarbuttons.png
With Titlebar enabled the buttons are a more visible darker gray.
(Reporter)

Updated

a year ago
Summary: [NIGHTLY 59] Option to Hide Titlebar works -- But makes browser window buttons hard to see, and completely disappear on Light and Dark theme. → [NIGHTLY 59] On Linux option to Hide Titlebar works -- But makes browser window buttons hard to see, and completely disappear on Light and Dark theme.

Updated

a year ago
Severity: normal → trivial
Component: Untriaged → Theme
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Blocks: gtktitlebar
Component: Theme → Widget: Gtk
Product: Firefox → Core
It seems this highly depends on your Theme
My system info:
Manjaro Linux
GTK Version: 3.22.26+47+g3a1a7135a2-3
Firefox nightly: 59.0a1.20171204-1 (from aur: firefox-nightly)
With Gnome version: 3.26.2-1

These are my results with various themes:
https://imgur.com/a/wUU2p
This is what I see on vanilla fedora 27. besides the default color scheme, the close window button is always gone. In the light and dark themes there is a stripe that appears on the top.

Also, I cannot move the window by dragging the CSD area, only the toolbar space, and weirdly the drop shadow.
Priority: -- → P3
The missing buttons at LWT themes are Bug 1424422
Missing dragging at titlebar is covered by Bug 1423851.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1424422
You need to log in before you can comment on or make changes to this bug.