rss feed does not display several authors

RESOLVED FIXED in Thunderbird 67.0

Status

defect
RESOLVED FIXED
2 years ago
5 months ago

People

(Reporter: bongilles, Assigned: alta88)

Tracking

(Depends on 1 bug)

Thunderbird 67.0
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments, 2 obsolete attachments)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171128222554

Steps to reproduce:

I added the following feed to Thunderbird: http://export.arxiv.org/api/query?search_query=cat:math.PR&start=0&max_results=99&sortBy=lastUpdatedDate&sortOrder=descending



Actual results:

Every article in the feed appear in Thunderbird as if it would have a single author.


Expected results:

For many articles several author should be displayed.
Component: Untriaged → Feed Reader
Product: Thunderbird → MailNews Core
Version: 52 Branch → 52
Well, the server seems to add a single author to the From: field, like
  From: Sai Song

Please inspect the message source, View > Message Source. Which message has more than one author?
Ok. I see what you mean. If I take the first message of today for this feed, only one author appears in the source of the message also there should be several. So maybe it comes from the server as you say. But if I open the same feed in other reader (e.g. Vienna), then several authors are displayed.
I put below the source for the same article both in Thunderbird and then in Vienna.

###########################
Source in Thunderbird:

From - Tue, 05 Dec 2017 18:21:04 GMT
X-Mozilla-Status: 0041
X-Mozilla-Status2: 00000000
X-Mozilla-Keys:                                                                                 
Received: by localhost; Wed, 6 Dec 2017 08:32:31 +0100
Date: Tue, 05 Dec 2017 18:21:04 GMT
Message-Id: <http://arxiv.org/abs/1708.02308v3@localhost.localdomain>
From: Anselmo Torresblanca-Badillo
MIME-Version: 1.0
Subject: Non-Archimedean pseudodifferential operators and Feller Semigroups
Keywords: math.PR,43A35; 46S10; 47G30 (primary); 60J25 (secondary)
Content-Transfer-Encoding: 8bit
Content-Base: http://arxiv.org/abs/1708.02308v3
Content-Type: text/html; charset=UTF-8

<html>
  <head>
    <title>Non-Archimedean pseudodifferential operators and Feller Semigroups</title>
    <base href="http://export.arxiv.org/api/query?search_query=cat:math.PR&amp;start=0&amp;max_results=99&amp;sortBy=lastUpdatedDate&amp;sortOrder=descending">
  </head>
  <body id="msgFeedSummaryBody" selected="false">
    In this article we study a class of non-Archimedean pseudodifferential
operators whose symbols are negative definite functions. We prove that these
operators extend to generators of Feller semigroups. In order to study these
operators, we introduce a new class of anisotropic Sobolev spaces, which are
the natural domains for the operators considered here. We also study the Cauchy
problem for certain pseudodifferential equations.
  </body>
</html>

###############################
Source (of the folder containing this article) in Vienna:

<?xml version="1.0" encoding="UTF-8"?>
<feed xmlns="http://www.w3.org/2005/Atom">
  <link href="http://arxiv.org/api/query?search_query%3Dcat%3Amath.PR%26id_list%3D%26start%3D0%26max_results%3D99" rel="self" type="application/atom+xml"/>
  <title type="html">ArXiv Query: search_query=cat:math.PR&amp;id_list=&amp;start=0&amp;max_results=99</title>
  <id>http://arxiv.org/api/0W/dxHVj6COWpbtobgtY89+OYO0</id>
  <updated>2017-12-06T00:00:00-05:00</updated>
  <opensearch:totalResults xmlns:opensearch="http://a9.com/-/spec/opensearch/1.1/">30774</opensearch:totalResults>
  <opensearch:startIndex xmlns:opensearch="http://a9.com/-/spec/opensearch/1.1/">0</opensearch:startIndex>
  <opensearch:itemsPerPage xmlns:opensearch="http://a9.com/-/spec/opensearch/1.1/">99</opensearch:itemsPerPage>
  <entry>
    <id>http://arxiv.org/abs/1708.02308v3</id>
    <updated>2017-12-05T18:21:04Z</updated>
    <published>2017-08-07T21:11:03Z</published>
    <title>Non-Archimedean pseudodifferential operators and Feller Semigroups</title>
    <summary>  In this article we study a class of non-Archimedean pseudodifferential
operators whose symbols are negative definite functions. We prove that these
operators extend to generators of Feller semigroups. In order to study these
operators, we introduce a new class of anisotropic Sobolev spaces, which are
the natural domains for the operators considered here. We also study the Cauchy
problem for certain pseudodifferential equations.
</summary>
    <author>
      <name>Anselmo Torresblanca-Badillo</name>
    </author>
    <author>
      <name>W. A. Zúñiga-Galindo</name>
    </author>
    <arxiv:comment xmlns:arxiv="http://arxiv.org/schemas/atom">Due to a calculation error, the results hold only for
  pseudodifferential equations "with constant coefficients"</arxiv:comment>
    <link href="http://arxiv.org/abs/1708.02308v3" rel="alternate" type="text/html"/>
    <link title="pdf" href="http://arxiv.org/pdf/1708.02308v3" rel="related" type="application/pdf"/>
    <arxiv:primary_category xmlns:arxiv="http://arxiv.org/schemas/atom" term="math.PR" scheme="http://arxiv.org/schemas/atom"/>
    <category term="math.PR" scheme="http://arxiv.org/schemas/atom"/>
    <category term="43A35, 46S10, 47G30 (primary), 60J25 (secondary)" scheme="http://arxiv.org/schemas/atom"/>
  </entry>
  <entry>
###
# here info of the next entry
###
  </entry>
###
# more entries
###
</feed>
Thanks for the information, our feeds expert will look into it.
There is an ancient comment about supporting multiple authors and this is valid. However, From is not actually handled correctly in feeds in general. As a coerced email message header, From must follow RFC 5322 and especially RFC 6854. Sadly, jsmime does not handle 6854 (despite being a prereq for landing it was never done).

It's also not clear how multiple authors should be displayed; one Author field with comma separated list (probably), or multiple Author field with one author each. The big problem is search, which assumes strict email formatting (and only 1 From is valid spec). So there could be issues with the back end and not just the simple matter of the parser handling multiple authors.

I would consider looking at it, but it's not pointful until all outstanding r? patches land.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Posted patch authorsAtom.patch (obsolete) — Splinter Review

Add support for multiple authors in Atom feeds. This also fixes Bug 1522156, as an email-less author must be angle bracket enclosed and function as an addr-spec (even though it isn't, per spec, and groups syntax can't be used either), for gloda to work.

A separate bug is for gloda support of multiple authors.

Assignee: nobody → alta88
Attachment #9042234 - Flags: review?(mkmelin+mozilla)

Indicate multiple authors in threadpane From with "et al.", the well known abbreviation for academic and legal etc. citations in en locales.

Attachment #9042236 - Flags: review?(jorgk)
Comment on attachment 9042236 [details] [diff] [review]
authorsMulti.patch

Review of attachment 9042236 [details] [diff] [review]:
-----------------------------------------------------------------

Looks OK, but please remove the left-over debug.
Attachment #9042236 - Flags: review?(jorgk) → review+
Comment on attachment 9042234 [details] [diff] [review]
authorsAtom.patch

Review of attachment 9042234 [details] [diff] [review]:
-----------------------------------------------------------------

Some comments below, but... then I realized, you should better just use existing functionality to build the mime header. Like lightning does in encodeMimeHeader: https://searchfox.org/comm-central/source/calendar/lightning/modules/ltnInvitationUtils.jsm#511

::: mailnews/extensions/newsblog/content/FeedItem.js
@@ +312,5 @@
> + * headers).
> + *
> + * @param  {String} headerName                      - Name of the header.
> + * @param  {String} || {String}[] headerItemsArray  - A string or an Array of
> + *                                                    strings to concatenate.

I think there is no need to push the complexity of array or not into here.
You're only using it at one place, so just pass [this.author] there instead

@@ +330,5 @@
> +    let items = [].concat(headerItemsArray);
> +    let lines = [];
> +    headerStr = HEADER;
> +    while (items.length) {
> +      item = items.shift();

let item = here instead of declaring it above
Attachment #9042234 - Flags: review?(mkmelin+mozilla) → review-

(In reply to Magnus Melin [:mkmelin] from comment #8)

Comment on attachment 9042234 [details] [diff] [review]
authorsAtom.patch

Review of attachment 9042234 [details] [diff] [review]:

Some comments below, but... then I realized, you should better just use
existing functionality to build the mime header. Like lightning does in
encodeMimeHeader:
https://searchfox.org/comm-central/source/calendar/lightning/modules/
ltnInvitationUtils.jsm#511

What? We currently store spec compliant UTF8 (RFC6532) in fields and everything works fine. Why would you propose converting to an RFC2047 encoding:

"=?UTF-8?B?PEFuZHJlYXMgR8O2YmVsPiwgPFRpbW8gS8O2dHppbmc+LCA8TWFy?= =?UTF-8?Q?tin_S=2e_Krejca=3e?="

instead of:

"<Andreas Göbel>, <Timo Kötzing>, <Martin S. Krejca>"

RFC2047 encoding should be killed with fire in this day and age. Further, the goal in feeds is to remove xpcom, not add more uses of it. And that function doesn't pretty format, which is a goal of createHeaderStrFromArray() when viewing source for messages. Finally, cargo culting stuff just because it's in lightning is a non reason.

The other nits are updated.

Attachment #9042234 - Attachment is obsolete: true
Attachment #9042751 - Flags: review?(mkmelin+mozilla)
Depends on: 1526985
Comment on attachment 9042751 [details] [diff] [review]
authorsAtom.patch

Review of attachment 9042751 [details] [diff] [review]:
-----------------------------------------------------------------

Alright, r=mkmelin
Attachment #9042751 - Flags: review?(mkmelin+mozilla) → review+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/89417f102fda
Support multiple authors in RSS feeds. r=mkmelin,jorgk CLOSED TREE

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED

Landed merged patch with the debug prints removed from nsMsgDBView.cpp.

Target Milestone: --- → Thunderbird 67.0

Please submit a patch to fix the linting failures :-(

Flags: needinfo?(alta88)

Adds the equivalent string for SeaMonkey

Attachment #9043857 - Flags: review?(frgrahl)

Oops, we forgot :-(

jorg, i hadn't asked for checkin yet since i was still pondering managing this given the gloda search issues and another issue perhaps related to an old friend (Bug 1023285), and was leaning to waiting until those were sorted. but no worries.

Flags: needinfo?(alta88)
Posted patch authorsLint.patch (obsolete) — Splinter Review
Attachment #9043905 - Flags: review?(jorgk)
Attachment #9043905 - Attachment is obsolete: true
Attachment #9043905 - Flags: review?(jorgk)
Attachment #9043910 - Flags: review?(jorgk)

(In reply to alta88 from comment #17)

jorg, i hadn't asked for checkin yet since i was still pondering managing this given the gloda search issues and another issue perhaps related to an old friend (Bug 1023285), and was leaning to waiting until those were sorted. but no worries.

My apologies! You know me situation, always hunting for landable patches :-( - You are quite right, it's not ready until the author says so. Thanks for the lint patch, I couldn't make much sense of Missing JSDoc, now I see the linter even reads comments.

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/725cf6d6c35d
Follow-up: Fix lint errors. r=jorgk CLOSED TREE
Attachment #9043910 - Flags: review?(jorgk) → review+
Comment on attachment 9043857 [details] [diff] [review]
Strings for SeaMonkey

Review of attachment 9043857 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks
Attachment #9043857 - Flags: review?(frgrahl) → review+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/bfdb7f18ed36
rss feed does not display several authors - SM part. r=frg

I'm pretty sure this test failure comes from here:
TEST-UNEXPECTED-FAIL | comm/mailnews/base/test/unit/test_nsMsgDBView_headerValues.js | real_test/< - [real_test/< : 63] "John Doe et al." == "John Doe"

Please submit a fix.

Flags: needinfo?(alta88)

oops. xpcshell test verified locally.

Flags: needinfo?(alta88)
Attachment #9044368 - Flags: review?(jorgk)
Comment on attachment 9044368 [details] [diff] [review]
etalTest.patch

Thanks, every little bit helps.
Attachment #9044368 - Flags: review?(jorgk) → review+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/0fe50bd26352
Follow-up: Adjust expectation of xpcshell test. r=jorgk

Another test affected. Was this landed without a try run?

Attachment #9044431 - Flags: review?(jorgk)
Comment on attachment 9044431 [details] [diff] [review]
1423487.patch test-display-name.js

What does Marco always say: Buuuuaaah :-(

Well, the other Xpcshell fix was landed with a local run and no one knew that this failure came from here. Thanks for fixing!

Oh, you mean the initial patch, well yes, apparently no try run.
Attachment #9044431 - Flags: review?(jorgk) → review+

https://hg.mozilla.org/comm-central/rev/8b3ebdb0d5381bd2c773215e89a3c1b76edd6f1f
adapt test-display-name.js to displaying multiple recipients in From column. r=jorgk

Blocks: 1522156
You need to log in before you can comment on or make changes to this bug.