Closed Bug 1423560 Opened 3 years ago Closed 3 years ago

On bluestarcoffeeroasters.com the "Expiry" field from credit card section doesn't display all the card saved entries

Categories

(Toolkit :: Form Autofill, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox59 --- affected

People

(Reporter: Ovidiu, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [form autofill:V2])

Affected versions]:

Tested on Nightly 59.0a1(2017-12-05)

[Affected platforms]:

Tested on Mac OS X 10.13, 10.11, Windows 10, 7 and Ubuntu 16.04

[Steps to reproduce]:

Prerequisites:
 1. Make sure you have at least two saved profile also with credit card
 
 
1. Go to https://bluestarcoffeeroasters.com/
2. Click on buy and go to checkout 
3. In the credit card section(at the bottom of the page) try to fill in the 2 sections.
4. Click on "Expiry" field.

[Expected result]:

The credit card sections are filled in with the data from the saved profiles. 

[Actual result]:

The "Expiry" field doesn't show all the saved entries. 


NOTE: Please see the video for the actual result: https://streamable.com/mi212
We use this site for testing the "2 address sections in a single form" but we saw that credit card fields are not working as expected, I'm not sure if we should use the block bug the [Meta] Form Autofill doesn't work well with specific sites.
Whiteboard: [form autofill:V2]
I can't reproduce this issue using Latest Nightly 59.0a1 on Windows 7 x64 with Build ID 20171206100053
(In reply to ovidiu boca[:Ovidiu] from comment #1)
> We use this site for testing the "2 address sections in a single form" but
> we saw that credit card fields are not working as expected, I'm not sure if
> we should use the block bug the [Meta] Form Autofill doesn't work well with
> specific sites.
I think it's fine to put it under compatibility meta.

(In reply to Valentina Claudia Ona from comment #2)
> I can't reproduce this issue using Latest Nightly 59.0a1 on Windows 7 x64
> with Build ID 20171206100053

I can't either. Using latest m-c build on Mac. Since the expiry field has correct attr autocomplete="cc-exp", it shouldn't be heuristics problem.
I think I got the point. I saw the video again and found that the one of your credit card profile has no expiration data, so it's expected that we show only one suggestion item when you clicking on cc-exp field.
Hi Ray,

We verified this on Windows 10 and Mac OS X 10.12 and we can't reproduce this issue anymore, we used the same profiles like the one form the video(they had the expiration date set). If we will encounter this issue in the future we will reopen it, until then I think we can close this issue as resolved WFM. Thanks
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.