Closed Bug 1423649 Opened 2 years ago Closed 2 years ago

Build fails with VS2017 due to gtest (error C4996: 'std::tr1': warning STL4002)

Categories

(Firefox Build System :: General, defect)

Unspecified
Windows
defect
Not set

Tracking

(firefox59 fixed)

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: Dexter, Assigned: RyanVM)

References

Details

Attachments

(1 file)

> gtest/gtest-printers.h(615): error C4996: 'std::tr1': warning STL4002: The non-Standard std::tr1 namespace and TR1-only machinery are deprecated and will be REMOVED. You can define _SILENCE_TR1_NAMESPACE_DEPRECATION_WARNING to acknowledge that you have received this warning.

Today's mozilla-central fails to build on Windows 10 with Visual Studio 2017 community with the error above.
This fixes the gtest TR1 errors and mozalloc operator new bustage.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=134521ee90d43e4a3f9d4ecf2584923faa0d1f8f

I've verified that VS2015 15.4 builds are still green as well.
Assignee: nobody → ryanvm
Status: NEW → ASSIGNED
Attachment #8935629 - Flags: review?(mh+mozilla)
Comment on attachment 8935629 [details] [diff] [review]
fix compiler errors with VS2017 15.5

Looks like Win64 PGO has issues related to the 15.5 update, but that doesn't need to block this bug. Our existing builds on 15.4 still work fine with this patch.
Attachment #8935629 - Flags: review?(mh+mozilla) → review?(core-build-config-reviews)
Comment on attachment 8935629 [details] [diff] [review]
fix compiler errors with VS2017 15.5

Review of attachment 8935629 [details] [diff] [review]:
-----------------------------------------------------------------

resembles what I saw go by on irc yesterday. r=me
Attachment #8935629 - Flags: review?(core-build-config-reviews) → review+
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b29d4a64f589
Fix compiler errors that happen when building with VS2017 15.5. r=rillian
https://hg.mozilla.org/mozilla-central/rev/b29d4a64f589
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Duplicate of this bug: 1427477
Blocks: VS15.6
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.