Crash in webrender::platform::windows::font::FontContext::create_glyph_analysis

RESOLVED FIXED in Firefox 66

Status

()

P3
critical
RESOLVED FIXED
a year ago
2 months ago

People

(Reporter: darkspirit, Assigned: lsalzman)

Tracking

(Blocks: 2 bugs, {crash, nightly-community})

Trunk
mozilla66
x86_64
Windows
crash, nightly-community
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox57 unaffected, firefox58 unaffected, firefox59 disabled, firefox64 disabled, firefox65 disabled, firefox66 fixed)

Details

(crash signature)

Seen on Socorro.

bp-7a26273d-34c6-49a9-937d-5915e0171130 Build 20171129111030 (2017-11-29) @ Windows 7
> assertion failed: hr == 0

>  GraphicsCriticalError 	
> |[G0][GFX1-]: WR: ERROR: Invalid window dimensions! Please call api.set_window_size() (t=448.172) |[G571][GFX1-]: WR: ERROR: Invalid window dimensions! Please call api.set_window_size() (t=1073.89) |[G572][GFX1-]: WR: ERROR: Invalid window dimensions! Please call api.set_window_size() (t=1073.89) |[G558][GFX1-]: WR: ERROR: Invalid window dimensions! Please call api.set_window_size() (t=471.016) |[G559][GFX1-]: WR: ERROR: Invalid window dimensions! Please call api.set_window_size() (t=471.066) |[G560][GFX1-]: WR: ERROR: Invalid window dimensions! Please call api.set_window_size() (t=471.066) |[G561][GFX1-]: WR: ERROR: Invalid window dimensions! Please call api.set_window_size() (t=471.119) |[G562][GFX1-]: WR: ERROR: Invalid window dimensions! Please call api.set_window_size() (t=471.119) |[G563][GFX1-]: WR: ERROR: Invalid window dimensions! Please call api.set_window_size() (t=471.119) |[G564][GFX1-]: WR: ERROR: Invalid window dimensions! Please call api.set_window_size() (t=471.169) |[G565][GFX1-]: WR: ERROR: Invalid window dimensions! Please call api.set_window_size() (t=471.169) |[G566][GFX1-]: WR: ERROR: Invalid window dimensions! Please call api.set_window_size() (t=471.222) |[G567][GFX1-]: WR: ERROR: Invalid window dimensions! Please call api.set_window_size() (t=471.275) |[G568][GFX1-]: WR: ERROR: Invalid window dimensions! Please call api.set_window_size() (t=474.017) |[G569][GFX1-]: WR: ERROR: Invalid window dimensions! Please call api.set_window_size() (t=474.33) |[G570][GFX1-]: WR: ERROR: Invalid window dimensions! Please call api.set_window_size() (t=1073.89) 

> 0 	xul.dll 	std::panicking::rust_panic_with_hook 	src/libstd/panicking.rs:583
> 1 	xul.dll 	std::panicking::begin_panic<str*> 	src/libstd/panicking.rs:538
> 2 	xul.dll 	webrender::platform::windows::font::FontContext::create_glyph_analysis 	gfx/webrender/src/platform/windows/font.rs:209
> 3 	xul.dll 	rayon::iter::internal::bridge_producer_consumer::helper<rayon::slice::IterProducer<webrender::glyph_rasterizer::GlyphRequest>, rayon::iter::map::MapConsumer<rayon::iter::collect::consumer::CollectConsumer<webrender::glyph_rasterizer::GlyphRasterJob>, closure>> 	third_party/rust/rayon/src/iter/internal.rs:268
> 4 	xul.dll 	rayon_core::job::{{impl}}::execute<closure> 	third_party/rust/rayon-core/src/job.rs:142
> 5 	xul.dll 	rayon_core::registry::in_worker<closure, ((), ())> 	third_party/rust/rayon-core/src/registry.rs:588
> 6 	xul.dll 	rayon::iter::internal::bridge_producer_consumer::helper<rayon::slice::IterProducer<webrender::glyph_rasterizer::GlyphRequest>, rayon::iter::map::MapConsumer<rayon::iter::collect::consumer::CollectConsumer<webrender::glyph_rasterizer::GlyphRasterJob>, closure>> 	third_party/rust/rayon/src/iter/internal.rs:275
> 7 	xul.dll 	rayon_core::registry::in_worker<closure, ((), ())> 	third_party/rust/rayon-core/src/registry.rs:588
> 8 	xul.dll 	rayon::iter::internal::bridge_producer_consumer::helper<rayon::slice::IterProducer<webrender::glyph_rasterizer::GlyphRequest>, rayon::iter::map::MapConsumer<rayon::iter::collect::consumer::CollectConsumer<webrender::glyph_rasterizer::GlyphRasterJob>, closure>> 	third_party/rust/rayon/src/iter/internal.rs:275
> 9 	xul.dll 	rayon_core::job::{{impl}}::execute<closure> 	third_party/rust/rayon-core/src/job.rs:142
> 10 	xul.dll 	rayon_core::registry::WorkerThread::wait_until<rayon_core::latch::CountLatch> 	third_party/rust/rayon-core/src/registry.rs:433
> 11 	xul.dll 	std::sys_common::backtrace::__rust_begin_short_backtrace<closure, ()> 	src/libstd/sys_common/backtrace.rs:131
> 12 	xul.dll 	alloc::boxed::{{impl}}::call_box<(), closure> 	src/liballoc/boxed.rs:725
> 13 	xul.dll 	std::sys::imp::thread::{{impl}}::new::thread_start 	src/libstd/sys/windows/thread.rs:54
> 14 		@0x900a2 	
> 15 	ntdll.dll 	RtlUserThreadStart 	
> 16 	kernel32.dll 	BasepReportFault 	
> 17 	kernel32.dll 	BasepReportFault
Whiteboard: [wr-mvp] [triage]
Crash Signature: [@ webrender::platform::windows::font::FontContext::create_glyph_analysis ] → [@ webrender::platform::windows::font::FontContext::create_glyph_analysis ] [@ static struct dwrote::glyph_run_analysis::GlyphRunAnalysis webrender::platform::windows::font::FontContext::create_glyph_analysis ]
If this is only happening on Win7 it doesn't block release.
Blocks: 1386674
No longer blocks: 1386669
(Reporter)

Updated

3 months ago
See Also: → bug 1514810
(Reporter)

Updated

3 months ago
Duplicate of this bug: 1514810
(Reporter)

Comment 3

3 months ago
Also happening on Win10:
https://crash-stats.mozilla.com/search/?app_notes=~WR%2B&build_id=%3E%3D20181212051241&proto_signature=~FontContext&platform=Windows&process_type=gpu&date=%3E%3D2018-12-10T19%3A01%3A42.000Z&date=%3C2018-12-17T19%3A01%3A42.000Z&_sort=-date&_facets=signature&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#crash-reports
Blocks: 1386669
No longer blocks: 1386674
Crash Signature: [@ webrender::platform::windows::font::FontContext::create_glyph_analysis ] [@ static struct dwrote::glyph_run_analysis::GlyphRunAnalysis webrender::platform::windows::font::FontContext::create_glyph_analysis ] → [@ webrender::platform::windows::font::FontContext::create_glyph_analysis ] [@ static struct dwrote::glyph_run_analysis::GlyphRunAnalysis webrender::platform::windows::font::FontContext::create_glyph_analysis ] [@ ?MOZ_CrashOOL@@YAXPEBDH0@Z.llvm.1176042…
status-firefox64: --- → disabled
status-firefox65: --- → disabled
status-firefox66: --- → affected
OS: Windows 7 → Windows
Whiteboard: [wr-mvp] [triage]
Parking with Lee because fonts.
Assignee: nobody → lsalzman
(Assignee)

Updated

2 months ago
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
status-firefox66: affected → fixed
status-firefox-esr60: --- → unaffected
Target Milestone: --- → mozilla66
You need to log in before you can comment on or make changes to this bug.