[GTK+ 3.10.8 / JWM] Window control buttons not properly displayed when tabs in titlebar on Linux

REOPENED
Assigned to

Status

()

defect
P3
normal
REOPENED
a year ago
8 months ago

People

(Reporter: terrell.kelley, Assigned: stransky)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171207220423

Steps to reproduce:

1. Download latest Linux 32-bit Nightly (59 branch)
2. Turn off titlebar in about:config or options

Possible Prerequisites:

- JWM window manager. 
- GTK 3.10.8 (Maximum for Ubuntu 14.04, which is still supported until 2019.)



Actual results:

Minimize and Maximize buttons are not displayed at all. Close button is displayed with a missing image placeholder.


Expected results:

Buttons should exist for Minimize and Maximize, and all should have existing images.
(Reporter)

Updated

a year ago
Blocks: gtktitlebar

Updated

a year ago
Component: Untriaged → Widget: Gtk
OS: Unspecified → Linux
Product: Firefox → Core
Hardware: Unspecified → x86
Priority: -- → P3
(Reporter)

Comment 1

a year ago
One thing to add: the buttons do properly appear if I switch to full screen mode. I would be fine with my distro just having those buttons.
(Assignee)

Comment 2

a year ago
It may be fixed by Bug 1408335
(Assignee)

Updated

a year ago
Summary: Window control buttons not properly displayed when tabs in titlebar on Linux → [GTK+ 3.10.8 / JWM] Window control buttons not properly displayed when tabs in titlebar on Linux
(Assignee)

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1408335
(Reporter)

Comment 4

a year ago
Assuming that bug 1408335 has been rolled out in Nightly, it does not seem to have fixed my issue. It did get rid of the broken image for the close button, but now it is blank. And I don't have the other buttons at all, just a blank space. 

This should probably be re-opened and no longer marked as a duplicate.

Suggestions for a fix: is there any way to detect if the buttons are drawn? Could you, if they aren't drawn, automatically just bring in the buttons from fullscreen mode? As I said, those work just fine.
(Assignee)

Comment 5

a year ago
Okay, re-opening per your request.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
(Assignee)

Comment 6

a year ago
I'm afraid I'd need to install the JWM manager to fix this one.
Assignee: nobody → stransky
(Reporter)

Comment 7

8 months ago
I simply wish to note that, currently, I have to set XDG_CURRENT_DESKTOP=XFCE to be able to remove the titlebar at all, meaning Firefox doesn't currently know I'm using JWM. 

I do have all the buttons, though. They just are blank. What I wish is that the icons used in full screen mode would also be used in maximized mode. Just detect if the image is blank, and then replace it with the full screen ones if they are. 

No need to especially go out and find the icons used for JWM.
You need to log in before you can comment on or make changes to this bug.