webpage devtools look (and behave) different than webextension devtools

RESOLVED DUPLICATE of bug 1362023

Status

()

Firefox
Developer Tools: Console
RESOLVED DUPLICATE of bug 1362023
a month ago
a month ago

People

(Reporter: andre.osku.schmidt, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a month ago
Created attachment 8935875 [details]
screenshot of webpage devtools and webextension devtools

webpage-devtools-vs-webextension-devtools.png shows how firefox 57.0.2 devtools for a webpage (above) and webextension (below) looks like on my system.

why do they look different?
(eg. webextension devtools has filter buttons and webpage devtools does not)

i first noticed it when using `console.groupCollapsed()` from my webextension and the log output is not collapsable at all. but if i open inspector for a "normal" html page, `console.groupCollapsed()` works as expected. https://github.com/oskude/BATT/issues/1

so i guess that webextension debugger - clicking debug in firefox extensions list - does not use the new devtools? https://bugzilla.mozilla.org/show_bug.cgi?id=1088360

if the case, can we make webextensions devtools also use devtools.webconsole.new-frontend-enabled (and devtools.debugger.new-debugger-frontend i guess)?

ps. i hope this is not a problem on my side, cause i use `firefox -p -no-remote` and `firefox-esr -p -no-remote` to run them at the same time...
(In reply to andre.osku.schmidt from comment #0)
> if the case, can we make webextensions devtools also use
> devtools.webconsole.new-frontend-enabled (and
> devtools.debugger.new-debugger-frontend i guess)?
> 
> ps. i hope this is not a problem on my side, cause i use `firefox -p
> -no-remote` and `firefox-esr -p -no-remote` to run them at the same time...

You are correct - the addon toolbox, browser toolbox, and browser console are all using the old console frontend. We have Bug 1362023 on file to fix this, but it depends on finishing porting over the browser console tests to the new frontend (tracked in Bug 1400847). Unfortunately we don't have a pref yet to optionally turn on the new frontend in these other toolboxes - this is hardcoded here: https://searchfox.org/mozilla-central/source/devtools/client/webconsole/hudservice.js#219.
Status: UNCONFIRMED → NEW
Component: Developer Tools → Developer Tools: Console
Ever confirmed: true
I'm going to dupe this to the bug on file that will enable the new UI for the addon toolbox - that bug will get resolved once it's updated.
Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1362023
You need to log in before you can comment on or make changes to this bug.