Enable new frontend in browser console

RESOLVED FIXED in Firefox 61

Status

enhancement
P1
normal
RESOLVED FIXED
2 years ago
10 months ago

People

(Reporter: bgrins, Assigned: bgrins)

Tracking

(Blocks 1 bug, {dev-doc-complete})

unspecified
Firefox 61
Dependency tree / graph

Firefox Tracking Flags

(firefox61 fixed)

Details

(Whiteboard: [newconsole-mvp])

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

2 years ago
Once the new frontend is loaded in an HTML document, we should have the browser console use it.

Note that the browser console, via hudservice, relies on a xul window to persist the width/height of the window.  So we will probably need to add a file like browser-console.xul that has a full width/height iframe pointing to webconsole.html, and then have hudservice load the xul file.
(Assignee)

Updated

2 years ago
Whiteboard: [console-html]
(Assignee)

Updated

2 years ago
Depends on: 1362036
(Assignee)

Updated

2 years ago
Depends on: 1307928
Flags: qe-verify?
Priority: -- → P2
Flags: qe-verify? → qe-verify+
QA Contact: iulia.cristescu
Priority: P2 → P3
Whiteboard: [console-html] → [reserve-console-html]
Priority: P3 → P4
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1394027

Updated

2 years ago
See Also: → 1393026
Blocks: 1397759
(Assignee)

Updated

2 years ago
Blocks: 1393914
(Assignee)

Updated

2 years ago
Blocks: 1378764
(Assignee)

Updated

2 years ago
Blocks: 1381834
(Assignee)

Updated

2 years ago
Blocks: 1380646
(Assignee)

Updated

2 years ago
Blocks: 1260877
Flags: qe-verify+
Priority: P4 → P2
QA Contact: iulia.cristescu
Whiteboard: [reserve-console-html] → [newconsole-mvp]
(Assignee)

Updated

a year ago
Duplicate of this bug: 1424357
See Also: → 1401963
(Assignee)

Updated

a year ago
Depends on: 1432232
(Assignee)

Comment 3

a year ago
I'm going to start looking into this since it seems like it's also going to require some changes to better support top-level HTML windows. For example here are some of the things I've noticed so far:

* persisting the width/height of the window after the user resizes it and then closes/reopens
* injecting top level menu items
* supporting context menu
* possibly commandDispatcher support (or removing the need for it in places like https://searchfox.org/mozilla-central/source/toolkit/content/macWindowMenu.js#24)

A workaround option would be to keep webconsole.xul but have it load a 100% width/height iframe pointing to webconsole.html. That seems like a pretty reasonable first step if we fix the other blockers of this bug but haven't worked out solutions to the above list.
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Priority: P2 → P1
Comment hidden (mozreview-request)
(Assignee)

Updated

a year ago
Depends on: 1435084
(Assignee)

Updated

a year ago
Depends on: 1435090
(Assignee)

Updated

a year ago
Attachment #8947648 - Attachment is obsolete: true
(Assignee)

Updated

a year ago
Attachment #8947649 - Attachment is obsolete: true
(Assignee)

Updated

a year ago
Depends on: 1435092
(Assignee)

Updated

a year ago
Depends on: 1436076
(Assignee)

Updated

a year ago
Depends on: 1436765
Summary: Enable new console in browser console → Enable new frontend in browser console
(Assignee)

Updated

a year ago
Depends on: 1438542
(Assignee)

Updated

a year ago
Depends on: 1439616
(Assignee)

Updated

a year ago
Depends on: 1438462
(Assignee)

Updated

a year ago
Depends on: 1440385
(Assignee)

Updated

a year ago
No longer depends on: 1438462
Comment hidden (mozreview-request)
(Assignee)

Updated

a year ago
Depends on: 1450186
Comment hidden (mozreview-request)
Comment on attachment 8947648 [details]
Bug 1362023 - Enable new frontend in the Browser Console unconditionally;

https://reviewboard.mozilla.org/r/217366/#review241838

yay :)
Attachment #8947648 - Flags: review?(nchevobbe) → review+

Comment 10

a year ago
Pushed by bgrinstead@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9866b049f5d8
Enable new frontend in the Browser Console unconditionally;r=nchevobbe
(Assignee)

Updated

a year ago

Comment 11

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/9866b049f5d8
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61

Updated

10 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.