autoscroll instantly starts on middle click

RESOLVED DUPLICATE of bug 1423810

Status

()

Core
Widget: Gtk
P5
normal
RESOLVED DUPLICATE of bug 1423810
a month ago
a month ago

People

(Reporter: Denis Lisov, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox57 unaffected, firefox58 unaffected, firefox59 fix-optional)

Details

(Reporter)

Description

a month ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171210100145

Steps to reproduce:

When autoscroll is enabled and I middle click on a long page, the autoscroll "compass" appears not right under cursor, but some distance above it, and the scrolling starts instantly. If I move the cursor to the center of the compass, scrolling stops as expected.

I've run mozregression and narrowed it to the landing of bug 1421794 ( https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=a27e933a27b65f220dabf6a5949ce15003485fd6&tochange=ed817bc6cc3bc2a11e9607afb3c5b52702ceb12a )
(Reporter)

Comment 1

a month ago
Sorry, landing of bug 1421974.

Updated

a month ago
Blocks: 1421974
Component: Untriaged → Widget: Gtk
Keywords: regression
Product: Firefox → Core

Updated

a month ago
status-firefox57: --- → unaffected
status-firefox58: --- → unaffected
status-firefox59: --- → affected
status-firefox-esr52: --- → unaffected
(Reporter)

Comment 2

a month ago
Forgot to mention initially that the desktop is Plasma 5.

Updated

a month ago
Duplicate of this bug: 1424767
status-firefox59: affected → fix-optional
Priority: -- → P5
Maybe Martin can take a look (IIRC Plasma is KDE)?
Flags: needinfo?(stransky)
(In reply to Denis Lisov from comment #0)
> User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101
> Firefox/59.0
> Build ID: 20171210100145
> 
> Steps to reproduce:
> 
> When autoscroll is enabled and I middle click on a long page, the autoscroll
> "compass" appears not right under cursor, but some distance above it, and
> the scrolling starts instantly. If I move the cursor to the center of the
> compass, scrolling stops as expected.
> 
> I've run mozregression and narrowed it to the landing of bug 1421794 (
> https://hg.mozilla.org/integration/autoland/
> pushloghtml?fromchange=a27e933a27b65f220dabf6a5949ce15003485fd6&tochange=ed81
> 7bc6cc3bc2a11e9607afb3c5b52702ceb12a )

Yes, that's caused by this commit. I wonder why fix for Bug 1423810 does not work for you as it disables the container drawing.

Complete fix is waiting for review at Bug 1424974.
Flags: needinfo?(stransky)
(Reporter)

Comment 6

a month ago
(In reply to Martin Stránský [:stransky] from comment #5)
> Yes, that's caused by this commit. I wonder why fix for Bug 1423810 does not
> work for you as it disables the container drawing.
> 
> Complete fix is waiting for review at Bug 1424974.

Sorry, I had some system instability and had not updated Nightly since reporting the bug. Now I'm on Nightly 2017-12-19 and the bug is gone.
Great, Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1423810
You need to log in before you can comment on or make changes to this bug.