If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

import mail with mail folder named /. creates odd folder heirarchy

RESOLVED FIXED in mozilla1.8alpha4

Status

MailNews Core
Import
RESOLVED FIXED
16 years ago
9 years ago

People

(Reporter: stormpunk, Assigned: Cavin Song)

Tracking

(Blocks: 1 bug)

Trunk
mozilla1.8alpha4
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90; Q312461)
BuildID:    2002041711

Back in the days I used to use Outlook Express (last week)I had a folder 
named /. to house things that would come from a similarly named website. 
Outlook Express named this folder ..dbx
Mozilla imported my mail with mostly lots of trouble and then finally got all 
of it, however some folders were contained in the /. folder, which mozilla had 
named '.' sans quotes.


Reproducible: Always
Steps to Reproduce:
1. Create folder in Outlook Express named '/.' sans quotes
2. Go delete Folders.dbx as mozilla can't seem to figure out how that works and 
ends up skipping most of the folders if you don't
3. In mozilla, import mail from outlook express


Actual Results:  Look at how mozilla threw a duplicate of every folder inside 
the folder mozilla named '.'

Expected Results:  It should not duplicate every folder.

The help page speaks of a Import module which I should report this as part of, 
yet the page I use to report this bug with doesn't list that. One of these 
needs to be changed.

Comment 1

16 years ago
changing component to import -> Cavin
Assignee: bienvenu → cavin
Component: Mail Database → Import

Updated

16 years ago
QA Contact: gayatri → nbaca

Comment 2

16 years ago
There are some existing bugs about folder names with certain characters causing
problems... one I found is 140212.  

Updated

15 years ago
Blocks: 124287

Comment 3

13 years ago
I just checked in something that should fix this under Bug #219586
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.8alpha4
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.