Closed Bug 1424792 Opened 2 years ago Closed 2 years ago

Crash in xul.dll@0x67bf82 | webrender::platform::windows::font::FontContext::add_font

Categories

(Core :: Graphics: WebRender, defect, P3, critical)

x86_64
Windows 10
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- disabled

People

(Reporter: darkspirit, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: crash, nightly-community, Whiteboard: [wr-mvp] [triage])

Crash Data

Seen on Socorro. New and the only one (so far).

bp-586b619f-6dcd-4dfb-a5f5-a35490171211 20171210220040 (2017-12-10) Win10
> Crash Reason 	EXCEPTION_ILLEGAL_INSTRUCTION

> GraphicsCriticalError |[G0][GFX1-]: Incompatible CompositableHost at WebRenderBridgeParent. (t=0.51612) 

> IPCFatalErrorMsg Error deserializing 'ByteBuf'
(This message also appeared in bug 1424652.)

> 0 	xul.dll 	xul.dll@0x67bf82 	
> 1 	xul.dll 	webrender::platform::windows::font::FontContext::add_font 	gfx/webrender/src/glyph_rasterizer.rs:571
> 2 	xul.dll 	webrender::resource_cache::ResourceCache::add_font_template 	gfx/webrender/src/resource_cache.rs:326
> 3 	xul.dll 	webrender::resource_cache::ResourceCache::update_resources 	gfx/webrender/src/resource_cache.rs:300
> 4 	xul.dll 	webrender::render_backend::RenderBackend::run 	gfx/webrender/src/render_backend.rs:457
> 5 	xul.dll 	std::sys_common::backtrace::__rust_begin_short_backtrace<closure, ()> 	src/libstd/sys_common/backtrace.rs:131
> 6 	xul.dll 	alloc::boxed::{{impl}}::call_box<(), closure> 	src/liballoc/boxed.rs:725
> 7 	xul.dll 	std::sys::imp::thread::{{impl}}::new::thread_start 	src/libstd/sys/windows/thread.rs:54
> 8 	kernel32.dll 	BaseThreadInitThunk 	
> 9 	ntdll.dll 	RtlUserThreadStart
See Also: → 1424652
Duplicate of this bug: 1425761
Didn't happen again.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.