Closed Bug 1424909 Opened 2 years ago Closed 2 years ago

Progress meter for in-progress installs don't display properly

Categories

(Toolkit :: Add-ons Manager, defect, P3)

defect

Tracking

()

VERIFIED FIXED
mozilla60
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- fixed
firefox60 --- verified

People

(Reporter: soeren.hentzschel, Assigned: aswan)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image screenshot
Something broke in the add-on manager a few days ago. Please see the attached screenshot, I saw this multiple times in the last few days while installing / updating add-ons.
I'm inclined to fix this by simply ripping installs out of the listing here.
Priority: -- → P5
Summary: regression: style bug in the add-on manager → Progress meter for in-progress installs don't display properly
Hi Soren,
Can you please tell which versions are affected to set the flags?
Flags: needinfo?(cadeyrn)
(In reply to Valentina Claudia Ona from comment #2)
> Hi Soren,
> Can you please tell which versions are affected to set the flags?

It's a regression in Firefox 59 Nightly.

(In reply to Andrew Swan [:aswan] from comment #1)
> I'm inclined to fix this by simply ripping installs out of the listing here.

I'm not sure if I understand this correctly but add-on updates are also affected.

I am also not sure about the priority (P5). My internet connection is often very slow and I get almost every day add-on updates so for me it's a highly visible visual regression in a core component of Firefox.
Flags: needinfo?(cadeyrn)
12:05.73 INFO: Last good revision: cd942db65cf93dad9688937034ef7f8fb91e5379
12:05.73 INFO: First bad revision: 2297e770f16c7411ff64dce3349a9406a59a9129
12:05.73 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=cd942db65cf93dad9688937034ef7f8fb91e5379&tochange=2297e770f16c7411ff64dce3349a9406a59a9129

Regressed by bug 1263313.
(In reply to Andrew Swan [:aswan] from comment #1)
> I'm inclined to fix this by simply ripping installs out of the listing here.

Given you marked this P5, should we stop tracking it as a regression in 59?
Flags: needinfo?(aswan)
(In reply to Andrew Overholt [:overholt] from comment #5)
> Given you marked this P5, should we stop tracking it as a regression in 59?

I'm not sure exactly what the implications are of tracking as a regression, but this isn't a blocker for 59 if that's the issue.
Also, just looking at the screenshot, I am skeptical of the bug identified in comment 4, it looks much more likely to be related to bug 1422100.
Flags: needinfo?(aswan)
(In reply to Andrew Swan [:aswan] from comment #6)
> (In reply to Andrew Overholt [:overholt] from comment #5)
> Also, just looking at the screenshot, I am skeptical of the bug identified
> in comment 4, it looks much more likely to be related to bug 1422100.

mozregression identified bug 1263313 as regressor. Bug 1422100 can't be the regressor because the patch from bug 1422100 landed four days before bug 1263313, so it's not in the regression range.
Duplicate of this bug: 1426701
Duplicate of this bug: 1428602
Firefox 59 will reach the Beta channel very soon and it's a visible regression in the add-on manager of Firefox. It affects not only new add-on install but also all add-on updates. I see the bug almost every day. I am surprised there is no activity at all since one month…
I think we should address this, one way or another, sooner rather than later.
Priority: P5 → P3
Attachment #8944599 - Flags: review?(tomica)
Assignee: nobody → aswan
Comment on attachment 8944599 [details]
Bug 1424909 Remove stray bracket in extensions.xml

https://reviewboard.mozilla.org/r/214762/#review220414

o_O
Attachment #8944599 - Flags: review?(tomica) → review+
Pushed by aswan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8774529a88f4
Remove stray bracket in extensions.xml r=zombie
https://hg.mozilla.org/mozilla-central/rev/8774529a88f4
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Comment on attachment 8944599 [details]
Bug 1424909 Remove stray bracket in extensions.xml

Approval Request Comment
[Feature/Bug causing the regression]:
bug 1263313

[User impact if declined]:
visual glitch in about:addons

[Is this code covered by automated tests?]:
no

[Has the fix been verified in Nightly?]:
yes, manually

[Needs manual test from QE? If yes, steps to reproduce]: 
I don't think further manual verification is necessary

[List of other uplifts needed for the feature/fix]:
none

[Is the change risky?]:
no

[Why is the change risky/not risky?]:
The change is quite simple and from manual inspection, it just fixes an obvious typo.

[String changes made/needed]:
none
Attachment #8944599 - Flags: approval-mozilla-beta?
Comment on attachment 8944599 [details]
Bug 1424909 Remove stray bracket in extensions.xml

Typo fix, let's uplift for the beta 4 build. Happy to see this fixed in 59!
Attachment #8944599 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Looking good on latest Nightly.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.