Closed Bug 1425033 Opened 2 years ago Closed 2 years ago

FormAssistant.jsm references undefined 'content' variable

Categories

(Firefox for Android :: General, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 59
Tracking Status
firefox57 --- wontfix
firefox58 --- wontfix
firefox59 --- fixed

People

(Reporter: standard8, Assigned: jchen)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Caught via looking at enabling ESLint, in FormAssistant#_getBoundingContentRect:

```
for (let frame = aElement.ownerGlobal; frame.frameElement && frame != content;
          frame = frame.parent) {
```

However, since the code moved from browser.js to a .jsm, `content` is undefined.
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8652c5609292
Fix frame handling in FormAssistant; r=me
https://hg.mozilla.org/mozilla-central/rev/8652c5609292
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
I assume that this is something that can ride the trains, but feel free to set the status for 58 back to affected and nominate the patch for approval if you feel strongly otherwise.
You need to log in before you can comment on or make changes to this bug.