Closed Bug 1425186 Opened 3 years ago Closed 3 years ago

"extensions.ui.experiment.hidden" preference set to "false" changing to "true" on opening about:addons/Add-ons Manager

Categories

(Toolkit :: Add-ons Manager, defect)

x86_64
Windows 7
defect
Not set
major

Tracking

()

VERIFIED INVALID

People

(Reporter: Virtual, Unassigned)

Details

(Keywords: nightly-community)

1. Open about:addons/Add-ons Manager
2. Open in other tab "about:config" and change "extensions.ui.experiment.hidden" preference to "false"
3. Reload about:addons/Add-ons Manager tab
and see that "extensions.ui.experiment.hidden" preference is being changing to "true"
Summary: "extensions.ui.experiment.hidden" preference set to "false" changeing to on opening about:addons/Add-ons Manager → "extensions.ui.experiment.hidden" preference set to "false" changing to "true" on opening about:addons/Add-ons Manager
From Mossop on IRC,

So this is a pref that we use to cache whether certain categories of the add-ons manager are empty or not and so hide them when the UI first appears. So basically if there are no experiments in the system the bug is describing the expected behaviour
Status: NEW → RESOLVED
Closed: 3 years ago
Component: Preferences → Add-ons Manager
Product: Firefox → Toolkit
Resolution: --- → INVALID
But I had experiment/study that time and it still happened (see bug #1425187 comment #0, which experiment/study). Was it also intended?
Flags: needinfo?(jaws)
Studies and experiments are two separate things.
Flags: needinfo?(jaws)
You need to log in before you can comment on or make changes to this bug.