Closed Bug 1426102 Opened 2 years ago Closed 2 years ago

Remove preference security.use_sqldb as part of the upgrade to NSS 3.35

Categories

(Core :: Security: PSM, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1417677
Tracking Status
firefox59 --- affected

People

(Reporter: KaiE, Unassigned)

Details

As discussed in bug 1398932, the recent addition of preference
  security.use_sqldb

was mostly for testing purposes, while NSS had not yet changed its internal default.

The preference should be removed for Firefox 59, because:
- NSS 3.35 has been switched and the opt-in pref is now unnecessary
  (bug 1377940)
- Firefox 59 uses NSS 3.35 (1420060)
- the pref could potentially cause confusion to users, 
  because it CANNOT be used to switch back to classic DBM database
- on systems that don't want to use the new sql db at all, e.g.
  because of OS stability requirements, the system NSS might get patched
  to retain the old DBM default.
  Keeping the pref would require that all derivative products are
  patched in such environments, in addition to patching NSS.

I suggest to remove this pref prior to the Firefox 59 release.

This depends on mozilla-central picking up a newer snapshot of NSS trunk (bug 1420060) that includes the commit from bug 1377940. It currently uses an older snapshot.
Summary: Remove preference security.use_sqldb as part of the upgreade to NSS 3.35 → Remove preference security.use_sqldb as part of the upgrade to NSS 3.35
I just learned the removal was already done in bug 1417677.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1417677
You need to log in before you can comment on or make changes to this bug.