Closed Bug 1426348 Opened 2 years ago Closed 2 years ago

[Firefox Notes] If you use Markdown formatting for "Bold" and "Italic", the "Notes" sidebar wrongly loses focus after saving or syncing changes

Categories

(Core :: Web Painting, defect, P2)

x86_64
Windows
defect

Tracking

()

RESOLVED DUPLICATE of bug 1429027
Tracking Status
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- affected
firefox60 --- verified

People

(Reporter: cbadescu, Unassigned)

References

Details

Attachments

(1 file)

[Regression]:
- This issue seems to be a regression. I've managed to find a regression-window. Here are the results:
Last good revision: 7fb001f811d183095e9cfdd958c9215484377396
First bad revision: d5e1ed773fefe2eb9d52402dd74b5fea19b8b4a4
Pushlog: https://goo.gl/kosEDa

Matt, can you please take a look at this issue

[Affected versions]:
- Firefox Nightly 59.0a1

[Affected Platforms]:
- All Windows

[Prerequisites]:
- Have a Firefox profile with the latest "Firefox Notes" add-on version installed from Test Pilot experiment page: https://testpilot.firefox.com/experiments/notes.

[Steps to reproduce]:
1. Open Firefox browser with the profile from prerequisites.
2. Type a bold word using markdown formatting (see https://goo.gl/9SJ4Ue).
3. Wait for the changes to be saved and observe the sidebar.

[Expected result]:
- The sidebar is focused.

[Actual result]:
- The sidebar loses its focus and the text caret disappears.

[Notes]:
- This issue is not reproducible for Heading, Ordered or Unordered lists.
- The text caret reappears if you press any key.
- Attached is a screen recording with the issue.
Flags: needinfo?(matt.woodrow)
Not reproducible with Firefox 57 but reproducible with current Nightly.
It is also reproducible in the CKEditor sandbox: https://ckeditor5.github.io/
I can't reproduce this with the latest Nightly. Is this platform specific?
Flags: needinfo?(matt.woodrow)
According to Cristina it happens on Windows.
Hello,

Indeed, I've encountered this issue only on Windows platform, to be more specific on Windows 10 x64. I didn't manage to reproduce it on Mac 10.12.6 or on Ubuntu 14.04 x64.

This is still reproducible, on latest Nightly build 59.0a1 (2018-01-10), using the latest version of the "Firefox Notes" add-on (2.2.0dev custom build from 01.10.2018) or "Firefox Notes" add-on version installed from Test Pilot experiment page: https://testpilot.firefox.com/experiments/notes.

Here is a screen recording with the issue: https://goo.gl/KtmE6k

Matt, can you please take another look at this issue?
Thanks.
Flags: needinfo?(matt.woodrow)
Blocks: 1352499
Priority: -- → P2
I believe that this bug was fixed by bug 1429027, and cannot reproduce this with the latest Nightly.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(matt.woodrow)
Resolution: --- → DUPLICATE
Duplicate of bug: 1429027
I've retested this issue and is no longer reproducible on latest Nightly build 60.0a1 (2018-01-24), using Firefox Notes from Test Pilot experiments page, on Windows 10 x64, Mac 10.12.6 and Ubuntu 14.04 x64.
You need to log in before you can comment on or make changes to this bug.