Closed Bug 1426410 Opened 2 years ago Closed 7 months ago

Misplaced Firefox update notification when using multiple monitors

Categories

(Toolkit :: Application Update, defect, P4)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: whimboo, Unassigned)

References

Details

Attachments

(1 file)

Attached image screenshot
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:59.0) Gecko/20100101 Firefox/59.0 ID:20171218220523

After opening the MacBook from sleep mode the update notification is shown at the upper right side of the screen totally disconnected from Firefox. See the screenshot.

Early that day the MacBook was connected to an external monitor with a higher resolution. Maybe that is causing this problem.
Doug, 0could you take a look at this?
Flags: needinfo?(dothayer)
I tried to close the notification now after filing this bug, but both buttons do not react, and so I'm not able to close it at all. Instead by issuing a mouse click at the original position closed the notification.
Priority: P4 → --
Priority: -- → P4
Doesn't sound like the update notification logic is responsible to me. Neil, does this ring any bells? It's a noautohide notification, if that is any help.
Flags: needinfo?(dothayer) → needinfo?(enndeakin)
noautohide panel*
Duplicate of this bug: 1428518
I don't think I've seen this. The description in comment 2 suggests that the system is moving the popup but not notifying us in some manner, or we aren't responding properly in some case.

Is this something that can be easily reproduced?
Flags: needinfo?(enndeakin)
This clearly has to do with a multi-monitor setup. I just have seen it today again for a Firefox 58 beta. I was not able to close the dialog, but once I connected the external monitor again the position was correct and elements reacted on mouse events.
Summary: Misplaced Firefox update notification → Misplaced Firefox update notification when using multiple monitors

Could you try reproducing this and after that see if the following also reproduces this by copying / pasting this into the browser console and pressing return. You will need the devtools.chrome.enabled pref set to true.

{
let action = {
label: "OK",
accessKey: "O",
callback: null,
};

let icon = "chrome://browser/skin/addons/addon-install-installed.svg";
let options = {
name: "Test",
message: "Test has been added to Firefox.",
popupIconURL: icon,
onDismissed: () => {
AppMenuNotifications.removeNotification("addon-installed");
resolve();
},
};

AppMenuNotifications.showNotification("addon-installed", action, null, options);
}

Flags: needinfo?(hskupin)

I haven't seen this problem for a very long time, so not sure if or how fast I would be able to give an answer to this question.

I would tend more to set this bug as WFM and reopen if I see it again.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → WORKSFORME

If you see it again please try to also reproduce it using the steps in comment #8. Chances are that this is specific to the UI code and affects other notifications than just app update.

Flags: needinfo?(hskupin)
You need to log in before you can comment on or make changes to this bug.