Closed Bug 1428518 Opened 2 years ago Closed 2 years ago

Restart to update Firefox dialog buttons do not work

Categories

(Toolkit :: Application Update, defect)

57 Branch
x86
Windows 10
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1426410

People

(Reporter: dazappa.matt, Unassigned)

References

Details

Attachments

(1 file)

Attached video 2018-01-05 22-29-31.mp4
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171226083017

Steps to reproduce:

In Windows 10, have 2 Firefox windows open on separate desktops. Let Firefox notify you there's an update available while on the second desktop.


Actual results:

Firefox 57.0.2 64 bit
Windows 10 64 bit.

"Restart and Restore" and "Not Now" buttons do not function. They appear in a dialog in desktop two. Upon double clicking the area above the two buttons, it appears to activate the features of the "Restart and Restore" button.


Expected results:

Let the buttons on the dialog work, regardless of which desktop is active. All that works is double clicking the area above the buttons.

Video timestamps.

00-10 : Clicking around, with no response
11 : Double clicking the area above the buttons seems to activate the Restart and Restore functionality. I believe the only reason it is switching to the first Firefox window in the first desktop is because closing a tab with Wordpress open caused a JS pop up.
19 : Double clicking the area above the buttons again (without dismissing the JS pop up, or closing the tab) and Firefox begins its update. I let the video run long enough to show that this process worked.
Blocks: 893505
Has STR: --- → yes
Component: Untriaged → Application Update
OS: Unspecified → Windows 10
Product: Firefox → Toolkit
Hardware: Unspecified → x86
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1426410
You need to log in before you can comment on or make changes to this bug.