Closed Bug 1426596 Opened 4 years ago Closed 4 years ago

Update ANGLE in 60

Categories

(Core :: Canvas: WebGL, enhancement, P1)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1440849
Tracking Status
firefox59 --- affected

People

(Reporter: jgilbert, Assigned: jgilbert)

References

Details

(Whiteboard: gfx-noted)

Attachments

(8 files)

Let's see if we can't pull an update real quick.

Here are the outstanding non-upstreamed patches:
https://public.etherpad-mozilla.org/p/angle-upstream-59

Fortunately, they're all pretty simple and should be easy to re-apply, though one of them had a file name change.
/builds/worker/workspace/build/src/obj-firefox/dist/include/angle/ShaderVars.h:291:31: error: suggest braces around initialization of subobject [-Werror,-Wmissing-braces] [log…] 

Oh..... Why can't we just spare those 3rd-party code......
https://treeherder.mozilla.org/#/jobs?repo=try&revision=70774d51e7aa8dc1ea3308405330a69980518fdc&selectedJob=153797731

Looks like there are a bunch of WebGL oranges, most of them are texture-related, maybe we still need some changes to apply it on.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=c5262d6f3553ccc8a1b65aa1adcdc0bebd6cccc0&selectedJob=154057984

After uplift patch in Bug 1347866, there is only one fail which is dom/canvas/test/webgl-conf/generated/test_conformance__textures__misc__texture-npot-video.html, I'm now finding which changeset we made in local is responsible for it.
Hi Jeff,

I'm quite sure I've applied our ANGLE local changesets which are not upstreamed yet,
but dom/canvas/test/webgl-conf/generated/test_conformance__textures__misc__texture-npot-video.html still fails,
and it doesn't look like a fail happens in previous ANGLE upgrade,
I think this fail has something to do with newer ANGLE's change.

Interestingly, we have an intermittent fail described in bug 1396649 which have exactly same failing pattern, I'm not sure about whether it is relevant, though.

Besides, we only have testfails in texture-npot-video.html, but not in texture-npot.html, so maybe the problem is related to video element.

I'm now investigating it, any suggestion about it?
Flags: needinfo?(jgilbert)
(In reply to Michael Leu[:Lenzak](UTC+8) from comment #4)
> https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=c5262d6f3553ccc8a1b65aa1adcdc0bebd6cccc0&selectedJob=1
> 54057984
> 
> After uplift patch in Bug 1347866, there is only one fail which is
> dom/canvas/test/webgl-conf/generated/
> test_conformance__textures__misc__texture-npot-video.html, I'm now finding
> which changeset we made in local is responsible for it.

That patch should not be necessary anymore. We should debug what's going wrong there. I upstreamed those changes already, so they should be in top-of-tree.
Flags: needinfo?(jgilbert)
I am quite sure that the patch in Bug 1325741 is not fully upstreamed yet.

We will fail those R11G11B10 float texture tests if we do not rebase the patch.
(In reply to Michael Leu[:Lenzak](UTC+8) from comment #11)
> I am quite sure that the patch in Bug 1325741 is not fully upstreamed yet.
> 
> We will fail those R11G11B10 float texture tests if we do not rebase the
> patch.

Identify and fix the bug without using the patch that's supposed to have been upstreamed. It's likely something wasn't quite upstreamed properly, but we shouldn't take that whole old patch to try to fix it. Fix it in a new patch.
It seems that ANGLE changes some of their extension name so we cannot correctly identify those which related to NV12 stream producers, we can fix it by updating gecko side's symbol declaration.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=4a797315667cca72841c3db8c6f214115e6e0a99

Now the texture-npot-video passed, I'm fixing the moz.build part on mac to make our cross-compiler happier.
Summary: Update ANGLE in 59 → Update ANGLE in 60
There are 2 issues left.

One is an assertion inside array-length-side-effect test in debug build, however, this test has no problem in release build, so I suspect it is an ANGLE bug, I'll build ANGLE standalone and write a simple cpp program to test ANGLE's debug build to verify it.

And the other is a fail in tex-3d-rgb11_11_10, it is very similar to the fail when we were updating ANGLE in bug 1371190, but this time is tex-3d instead of tex-2d, although this can be fixed by rebasing our old patch, I think this is caused by different problem and worthwhile to investigate it.
OK, I can confirm the crash inside array-length-side-effect is an ANGLE bug, I can reproduce it by writing a simple cpp program with building ANGLE translator standalone, I have reported it to Google.
https://bugs.chromium.org/p/angleproject/issues/detail?id=2307
https://chromium-review.googlesource.com/c/angle/angle/+/874691

ANGLE has fixed the shader compiler problem.

I'm sorry I cannot do it further.

Good bye.
Blocks: 1434522
Assignee: cleu → jgilbert
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: angle-60
You need to log in before you can comment on or make changes to this bug.