Update ANGLE to chromium/2950

RESOLVED FIXED in Firefox 55

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: cleu, Assigned: cleu)

Tracking

(Blocks: 2 bugs)

Trunk
mozilla55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 fixed)

Details

Attachments

(4 attachments, 3 obsolete attachments)

(Assignee)

Description

2 years ago
This version of ANGLE introduced several bugfix and support for Async/Multithread D3D shader compilation which improves its shader compile speed.
(Assignee)

Updated

2 years ago
Assignee: nobody → cleu
Blocks: 1212878
(Assignee)

Comment 1

2 years ago
Created attachment 8848992 [details] [diff] [review]
Update ANGLE to build 2950
(Assignee)

Comment 2

2 years ago
Created attachment 8848993 [details] [diff] [review]
Remove SH_UNROLL_FOR_LOOP_WITH_SAMPLER_ARRAY_INDEX flag which is unsupported by newer ANGLE
(Assignee)

Updated

2 years ago
Attachment #8848992 - Flags: review?(jgilbert)
(Assignee)

Updated

2 years ago
Attachment #8848993 - Flags: review?(jgilbert)
(Assignee)

Updated

2 years ago
Attachment #8848992 - Attachment is obsolete: true
Attachment #8848992 - Flags: review?(jgilbert)
(Assignee)

Updated

2 years ago
Attachment #8848993 - Attachment is obsolete: true
Attachment #8848993 - Flags: review?(jgilbert)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Assignee)

Comment 10

2 years ago
It seems that removing the for-loop unrolling flag cause mochitest-gl fail under Linux.

The flag is dropped in the changeset.
https://github.com/google/angle/commit/1b896c62934be40cf8a37dc28fabc15590c89a5d

I think we should revert it and apply this flag for only Linux.
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Assignee)

Updated

2 years ago
Attachment #8854696 - Attachment is obsolete: true
Attachment #8854696 - Flags: review?(jgilbert)
(Assignee)

Comment 15

2 years ago
Try looks good now after remove the changeset removing SH_UNROLL_FOR_LOOP_WITH_SAMPLER_ARRAY_INDEX
https://treeherder.mozilla.org/#/jobs?repo=try&revision=e474a501dded2c4834e0bc06d4f8b00b2bef2468&selectedJob=88789618

Comment 16

2 years ago
mozreview-review
Comment on attachment 8854693 [details]
Bug 1347866 - Part2: Revert "translator: remove code related to for-loop unrolling"

https://reviewboard.mozilla.org/r/126654/#review130796

Bug 1324972 was fixed upstream.
Attachment #8854693 - Flags: review?(jgilbert) → review-

Comment 17

2 years ago
mozreview-review
Comment on attachment 8854694 [details]
Bug 1347866 - Part3: ANGLE patch uplift for bug1325733;

https://reviewboard.mozilla.org/r/126656/#review130798
Attachment #8854694 - Flags: review?(jgilbert) → review+

Comment 18

2 years ago
mozreview-review
Comment on attachment 8854695 [details]
Bug 1347866 - Part4: ANGLE patch uplift for bug1325741;

https://reviewboard.mozilla.org/r/126658/#review130800
Attachment #8854695 - Flags: review?(jgilbert) → review+

Comment 19

2 years ago
mozreview-review
Comment on attachment 8854692 [details]
Bug 1347866 - Part1: Update ANGLE to chromium/2950;

https://reviewboard.mozilla.org/r/126652/#review130806

Update ANGLE in its own commit, and then add a commit that reverts anything. We need them to be separate so it's easy to track how much we differ from ANGLE upstream.
Attachment #8854692 - Flags: review?(jgilbert) → review-
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 24

2 years ago
mozreview-review
Comment on attachment 8854692 [details]
Bug 1347866 - Part1: Update ANGLE to chromium/2950;

https://reviewboard.mozilla.org/r/126652/#review131190
Attachment #8854692 - Flags: review?(jgilbert) → review+

Comment 25

2 years ago
mozreview-review
Comment on attachment 8854693 [details]
Bug 1347866 - Part2: Revert "translator: remove code related to for-loop unrolling"

https://reviewboard.mozilla.org/r/126654/#review131194

Please file a bug about trying to remove this requirement. We should figure out if Chrome's fixing this another way.
Attachment #8854693 - Flags: review?(jgilbert) → review+
(Assignee)

Updated

2 years ago
See Also: → bug 1355321
(Assignee)

Updated

2 years ago
Depends on: 1355321
See Also: bug 1355321
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 26

2 years ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2fd9927e85ae
Part1: Update ANGLE to chromium/2950; r=jgilbert
https://hg.mozilla.org/integration/autoland/rev/7aeaeae6fc91
Part2: Revert "translator: remove code related to for-loop unrolling" r=jgilbert
https://hg.mozilla.org/integration/autoland/rev/d9165d5725b7
Part3: ANGLE patch uplift for bug1325733; r=jgilbert
https://hg.mozilla.org/integration/autoland/rev/3caa5ec38d18
Part4: ANGLE patch uplift for bug1325741; r=jgilbert
Keywords: checkin-needed

Comment 27

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/d9165d5725b7
https://hg.mozilla.org/mozilla-central/rev/3caa5ec38d18
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox55: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
(Assignee)

Updated

2 years ago
Duplicate of this bug: 863316

Updated

2 years ago
Blocks: 1382851
You need to log in before you can comment on or make changes to this bug.