Open Bug 1426770 Opened 2 years ago Updated Last year

Bad performance on running displaylist_mutate talos test

Categories

(Core :: Graphics: WebRender, defect, P5)

x86_64
All
defect

Tracking

()

People

(Reporter: jrmuizel, Unassigned)

References

(Depends on 4 open bugs, Blocks 2 open bugs)

Details

(Whiteboard: [needs-investigation])

Currently we're probably worse than trunk on this. It shouldn't be too hard to do better.
Depends on: 1425863
Depends on: 1434696
Depends on: 1424968
Depends on: 1434243
Depends on: 1437091
Depends on: 1437097
https://treeherder.mozilla.org/perf.html#/graphs?series=autoland,1663497,1,1&series=autoland,1683784,1,1&series=autoland,1663687,1,1&series=autoland,1683809,1,1

Currently on Linux we are worse with WR enabled than WR disabled. On Windows we used to be slightly better, until bug 1452845 made us worse. Bug 1465784 is tracking that regression. Turning this into a P1 because of the Windows regression.
Depends on: 1465784
OS: Unspecified → All
Priority: P3 → P1
Hardware: Unspecified → x86_64
Summary: [meta] display-mutate talos test → Bad performance on running displaylist_mutate talos test
bug 1476636/bug 1455422 made this worse on both Linux and Windows. Also recently bug 1462672 landed which improved the non-WR perf on this test significantly so that widened the gap.
Blocks: 1476636
Depends on: 1477638
We can't release this to the field, but we can let this ride to beta.  However, we want to investigate and understand the bad perf numbers asap.
QA Whiteboard: [needs-investigation]
Priority: P1 → P2
QA Whiteboard: [needs-investigation]
Whiteboard: [needs-investigation]
Priority: P2 → P3
Priority: P3 → P2
Assignee: nobody → dglastonbury
Duplicate of this bug: 1501172
Priority: P2 → P4
Assignee: dglastonbury → nobody
Priority: P4 → P5
You need to log in before you can comment on or make changes to this bug.