Left clicking randomly stops working on pages

VERIFIED FIXED in Firefox 59

Status

()

defect
--
major
VERIFIED FIXED
a year ago
10 months ago

People

(Reporter: bruce.bugz, Assigned: stone)

Tracking

(Blocks 1 bug, {nightly-community, regression})

Trunk
Firefox 59
All
Windows
Points:
---
Bug Flags:
in-qa-testsuite +

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox57 unaffected, firefox58 unaffected, firefox59blocking verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171226100306

Steps to reproduce:

I don't have any STR, the issue appears to be random. Some information that might be relevant:

1) There is nothing relevant in the Web / Browser Consoles when this happens.
2) The issue is tab specific (maybe content process specific?). So it can happen that Lclick is not working on one tab but working fine on another.
3) Appears to be a recent Nightly regression
4) Others have reported the same issue here: https://www.reddit.com/r/firefox/comments/7me1lp/cant_click_on_pages_randomly/.

My about:support: http://txt.do/dc71f.

Comment 1

a year ago
I've noticed this when I start to type some text into a textbox, such as bugzillas, and then drag the window I was typing into onto a new monitor and try to start typing into the textbox again.
(Reporter)

Comment 2

a year ago
(In reply to Bruce from comment #0)
> 1) There is nothing relevant in the Web / Browser Consoles when this happens.

Please read the quoted line as: "1) There is nothing relevant in the Browser Console when this happens." Sorry, I hadn't been checking the Web Console. I will try to, the next time it happens.
I can confirm this. Whole website page is in active hover pointer/mouse cursor state.
Looks like new regression for about few days (max. week).
Only working workaround in my case is browser restart.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → Windows
Hardware: Unspecified → All
I notice this behavior on Google Maps when moving the map around.  At times it doesn't work when left clicking.

Comment 6

a year ago
Additional info:

* The bug is not limited to mouse interactions. Tabbing through elements or hitting Enter to activate an already-focused element also stops working.

* Searching for a string on the page is able to move the focus, however.

* Reloading the page in the same tab doesn't help, but if I open a second instance in an adjoining tab, it works. No browser restart needed, but the affected page tends to freeze again pretty quickly.
Duplicate of this bug: 1427768
FWIW, I think this needs to block any 59 Betas from going out next week.
I think I've seen this on 58 beta. It's possible that was an unrelated issue, though. Are we confident it's Nightly only?
Note there's also bug 1427461, which has a regression range. I'm not entirely sure it's the same bug but it sounds very similar.
This sounds severe enough that it should block 59 moving to beta.
(In reply to Emanuel Hoogeveen [:ehoogeveen] from comment #10)
> Note there's also bug 1427461, which has a regression range. I'm not
> entirely sure it's the same bug but it sounds very similar.

Yeah, the timing of bug 1414204 landing at least sounds plausible for when people started noticing it.
See Also: → 1427461
fwiw, also happened to me while working in a jupyter notebook after returning from another tab
stone, this may be related or even a duplicate, to bug 1427461.
Flags: needinfo?(sshih)
(Assignee)

Updated

a year ago
Assignee: nobody → sshih
Flags: needinfo?(sshih)
This should be fixed in current nightlies via the backout in bug 1414204. Feel free to reopen if you can still reproduce with an up-to-date build.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
I didn't encounter this issue for few days, so it was probably caused by bug #1414204.
Blocks: 1414204
Status: RESOLVED → VERIFIED
Flags: in-qa-testsuite+
You need to log in before you can comment on or make changes to this bug.