Closed Bug 1428137 Opened 3 years ago Closed 3 years ago

TV ran a Windows browser-chrome test that should have been skipped (os_version missing from mozinfo)

Categories

(Testing :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1428461

People

(Reporter: gbrown, Assigned: gbrown)

References

Details

TV is seeing mozinfo consistent with the build's mozinfo json:

{u'allow_legacy_extensions': True, u'pgo': False, u'sync': True, u'buildapp': u'browser', u'crashreporter': True, u'addon_signing': True, u'devedition': False, u'require_signing': False, u'platform_guess': u'win32', u'appname': u'firefox', u'stylo': True, u'mozconfig': u'z:/build/build/src/.mozconfig', u'topsrcdir': u'z:/build/build/src', u'telemetry': False, 'version': '6.1.7601', u'datareporting': True, u'buildtype_guess': u'opt', 'bits': 32, u'bin_suffix': u'.exe', 'service_pack': 'Service Pack 1', u'artifact': True, u'toolkit': u'windows', u'healthreport': True, u'updater': True, u'asan': False, u'release_or_beta': False, u'ccov': False, u'ubsan': False, u'tests_enabled': True, u'official': True, u'tsan': False, u'nightly_build': True, u'debug': False, 'os': u'win', 'processor': u'x86'}

It also has some run-time info, like 'version' -- but not 'os_version'.


runtests' mozinfo sees 'os_version': '6.1'
Depends on: 1428461
Summary: TV ran a Windows browser-chrome test that should have been skipped → TV ran a Windows browser-chrome test that should have been skipped (os_version missing from mozinfo)
This, and similar problems based on os_version, should be fixed by bug 1428461.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1428461
You need to log in before you can comment on or make changes to this bug.