Closed Bug 1428461 Opened 2 years ago Closed 2 years ago

mozharness copy of mozinfo is out of date

Categories

(Release Engineering :: Applications: MozharnessCore, defect)

defect
Not set

Tracking

(firefox59 fixed)

RESOLVED FIXED
Tracking Status
firefox59 --- fixed

People

(Reporter: gbrown, Assigned: gbrown)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

testing/mozharness/mozinfo was initially copied from testing/mozbase/mozinfo/mozinfo. mozbase's mozinfo has evolved, but most changes have not been migrated to mozharness.

One known consequence is bug 1428137.
For the most part, it looks easy to copy mozbase/mozinfo -> mozharness/mozinfo and all's well. There is a complication from the recent change in bug 1426330: It added a dependency on the "six" module, which isn't normally available in the mozharness environment. I'm not 100% sure, but I have a feeling it will be difficult to import six in mozinfo in mozharness.

:vedantc98/:wlach -- Would it be possible to not use "six" in mozinfo?
Flags: needinfo?(wlachance)
Flags: needinfo?(vedantc98)
See Also: → 1426330
Should be pretty trivial, we only use one part of six in mozinfo (stringtypes):

https://searchfox.org/mozilla-central/rev/0a895028f74cffa67561150d10700abca8a931d8/testing/mozbase/mozinfo/mozinfo/mozinfo.py#19

You could replace the calls to six with a copypaste from that file:

https://github.com/benjaminp/six/blob/master/six.py#L49

Would be happy to review a patch if you want to make one :)
Flags: needinfo?(wlachance)
Flags: needinfo?(vedantc98)
Blocks: 1406407
Great! Let's do that.
Attachment #8940375 - Flags: review?(wlachance)
Keywords: leave-open
Comment on attachment 8940375 [details] [diff] [review]
decouple mozinfo from six

Review of attachment 8940375 [details] [diff] [review]:
-----------------------------------------------------------------

wfm!
Attachment #8940375 - Flags: review?(wlachance) → review+
Comment on attachment 8940585 [details] [diff] [review]
update testing/mozharness/mozinfo from testing/mozbase/mozinfo/mozinfo

Review of attachment 8940585 [details] [diff] [review]:
-----------------------------------------------------------------

thanks for updating this
Attachment #8940585 - Flags: review?(jmaher) → review+
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1b4b7cb6959e
Decouple mozinfo from the six module; r=wlach
https://hg.mozilla.org/integration/mozilla-inbound/rev/66c7d59eb914
Update mozharness' mozinfo from mozbase; r=jmaher
Keywords: leave-open
Duplicate of this bug: 1428137
You need to log in before you can comment on or make changes to this bug.